aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2010-11-15 18:37:57 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-11-15 20:06:45 +0100
commitecd94a4b45924c3c65feabc87bbc7a075e951249 (patch)
treef3622b119e81c1c86c288a6273ce9e9bdba8841d /openbsc/src/Makefile.am
parent0b369c582b94c2b409417bcaed0fcdd90d925d9e (diff)
misc: Introduce a --enable-coverage mode to build with gprof coverage
This adds a test coverage build. One can use gcov and lcov on the resulting data afterwards to see which code paths were executed and which were not.
Diffstat (limited to 'openbsc/src/Makefile.am')
-rw-r--r--openbsc/src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/openbsc/src/Makefile.am b/openbsc/src/Makefile.am
index 1566af955..2766d938c 100644
--- a/openbsc/src/Makefile.am
+++ b/openbsc/src/Makefile.am
@@ -1,6 +1,6 @@
INCLUDES = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)
-AM_CFLAGS=-Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOVTY_CFLAGS)
-AM_LDFLAGS = $(LIBOSMOCORE_LIBS)
+AM_CFLAGS=-Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOVTY_CFLAGS) $(COVERAGE_CFLAGS)
+AM_LDFLAGS = $(LIBOSMOCORE_LIBS) $(COVERAGE_LDFLAGS)
# build current directory before building gprs
SUBDIRS = . ipaccess gprs