aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@netfilter.org>2009-12-23 22:44:04 +0100
committerHarald Welte <laforge@netfilter.org>2009-12-23 22:44:04 +0100
commit2ca7c3142989606590b45f661224a5b175f85dd4 (patch)
treeaeffb5e2c8435e933c437dfb3005e9643e942a8b /openbsc/src/Makefile.am
parentb7bcb79bea2b8b6afaf91ed253bcacffaedc3719 (diff)
Add ipaccess-proxy, a proxy for ip.access A-bis over IP
This proxy allows us to restart OpenBSC while the BTS's are kept running with their CCCH/BCCH alive. This is very useful to make sure the phones don't roam to other networks while restarting OpenBSC. The proxy also intrduces UDP sockets for injecting UDP packets into the A-bis data stream.
Diffstat (limited to 'openbsc/src/Makefile.am')
-rw-r--r--openbsc/src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/openbsc/src/Makefile.am b/openbsc/src/Makefile.am
index 3f98bdad9..54a8cde2d 100644
--- a/openbsc/src/Makefile.am
+++ b/openbsc/src/Makefile.am
@@ -2,7 +2,7 @@ INCLUDES = $(all_includes) -I$(top_srcdir)/include
AM_CFLAGS=-Wall
sbin_PROGRAMS = bsc_hack bs11_config ipaccess-find ipaccess-config \
- isdnsync bsc_mgcp ipaccess_firmware
+ isdnsync bsc_mgcp ipaccess_firmware ipaccess-proxy
noinst_LIBRARIES = libbsc.a libmsc.a libvty.a libsccp.a
noinst_HEADERS = vty/cardshell.h
@@ -40,3 +40,5 @@ bsc_mgcp_SOURCES = bsc_mgcp.c msgb.c talloc.c debug.c select.c timer.c telnet_in
bsc_mgcp_LDADD = libvty.a
ipaccess_firmware_SOURCES = ipaccess-firmware/ipaccess-firmware.c
+
+ipaccess_proxy_SOURCES = ipaccess-proxy.c msgb.c select.c talloc.c debug.c timer.c