aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2009-08-01 07:26:59 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2009-08-17 09:52:42 +0200
commit1494a768c14295a63cbf59f729dcf91a8b4d22ba (patch)
tree3a2c2fd3dbc862471423f5a1e2d51544e67199fe /openbsc/src/Makefile.am
parent93d4394d1d0e14a71e6cead8a895907c92cf7784 (diff)
[bsc] Move the GSM 04.08 helper functions to gsm_04_08_utils.c
The existing gsm_04_08.c implementation is mixing BSC and MSC behavior. Move some simple parsing and generation functions over to gsm_04_08_utils.c to allow a different MSC to define the policy.
Diffstat (limited to 'openbsc/src/Makefile.am')
-rw-r--r--openbsc/src/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/openbsc/src/Makefile.am b/openbsc/src/Makefile.am
index cd0a0e6a3..30968b021 100644
--- a/openbsc/src/Makefile.am
+++ b/openbsc/src/Makefile.am
@@ -5,16 +5,16 @@ sbin_PROGRAMS = bsc_hack bs11_config ipaccess-find ipaccess-config isdnsync
noinst_LIBRARIES = libbsc.a libmsc.a libvty.a
noinst_HEADERS = vty/cardshell.h
-libbsc_a_SOURCES = abis_rsl.c abis_nm.c gsm_data.c \
+libbsc_a_SOURCES = abis_rsl.c abis_nm.c gsm_data.c gsm_04_08_utils.c \
msgb.c select.c chan_alloc.c timer.c debug.c \
- gsm_subscriber_base.c subchan_demux.c bsc_rll.c \
+ gsm_subscriber_base.c subchan_demux.c bsc_rll.c transaction.c \
trau_frame.c trau_mux.c paging.c e1_config.c e1_input.c tlv_parser.c \
input/misdn.c input/ipaccess.c signal.c gsm_utils.c talloc.c \
talloc_ctx.c
libmsc_a_SOURCES = gsm_subscriber.c db.c telnet_interface.c \
- mncc.c rtp_proxy.c gsm_04_08.c gsm_04_11.c transaction.c token_auth.c \
- rrlp.c
+ mncc.c rtp_proxy.c gsm_04_08.c gsm_04_11.c transaction.c \
+ token_auth.c rrlp.c
libvty_a_SOURCES = vty/buffer.c vty/command.c vty/vector.c vty/vty.c