aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2010-05-01 14:02:25 +0200
committerHarald Welte <laforge@gnumonks.org>2010-05-01 14:02:25 +0200
commit0b484a4fb1641be2dadc822dbd9ad184268dcf9e (patch)
tree1ccf3f8846be6b647947dfed6bed703c2dbced8c /openbsc/src/Makefile.am
parent9624364b4eed534d99ddd4bb77d8f7fdab1bdb03 (diff)
Makefile cleanup
move vty_interface_cmds.c and telnet_interface.c into libvty rather than explicitly linking the C files for every program
Diffstat (limited to 'openbsc/src/Makefile.am')
-rw-r--r--openbsc/src/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/openbsc/src/Makefile.am b/openbsc/src/Makefile.am
index 2c1d37a04..38150a9bf 100644
--- a/openbsc/src/Makefile.am
+++ b/openbsc/src/Makefile.am
@@ -17,14 +17,15 @@ libbsc_a_SOURCES = abis_rsl.c abis_nm.c gsm_data.c gsm_04_08_utils.c \
input/misdn.c input/ipaccess.c \
talloc_ctx.c system_information.c rest_octets.c \
rtp_proxy.c bts_siemens_bs11.c bts_ipaccess_nanobts.c \
- bts_unknown.c bsc_version.c bsc_api.c vty_interface_cmds.c
+ bts_unknown.c bsc_version.c bsc_api.c
-libmsc_a_SOURCES = gsm_subscriber.c db.c telnet_interface.c \
+libmsc_a_SOURCES = gsm_subscriber.c db.c \
mncc.c gsm_04_08.c gsm_04_11.c transaction.c \
token_auth.c rrlp.c gsm_04_80.c ussd.c silent_call.c \
handover_logic.c handover_decision.c meas_rep.c
-libvty_a_SOURCES = vty/buffer.c vty/command.c vty/vector.c vty/vty.c
+libvty_a_SOURCES = vty/buffer.c vty/command.c vty/vector.c vty/vty.c \
+ telnet_interface.c vty_interface_cmds.c
libsccp_a_SOURCES = sccp/sccp.c
@@ -42,7 +43,7 @@ ipaccess_config_LDADD = libbsc.a libmsc.a libbsc.a libvty.a -ldl -ldbi $(LIBCRYP
isdnsync_SOURCES = isdnsync.c
bsc_mgcp_SOURCES = mgcp/mgcp_main.c mgcp/mgcp_protocol.c mgcp/mgcp_network.c mgcp/mgcp_vty.c \
- debug.c telnet_interface.c vty_interface_cmds.c
+ debug.c
bsc_mgcp_LDADD = libvty.a
ipaccess_proxy_SOURCES = ipaccess/ipaccess-proxy.c debug.c