aboutsummaryrefslogtreecommitdiffstats
path: root/libosmocore/src/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2010-03-22 22:25:13 +0800
committerHarald Welte <laforge@gnumonks.org>2010-03-22 22:25:13 +0800
commit351ec2a1784fbdb2ce688f50a9134532f3bf0723 (patch)
treed599030f3ffb4e563b73f5ede9a8e80fc1bc048f /libosmocore/src/Makefile.am
parente164d29e7f6c86d1f6f047bbf58159e46a11425f (diff)
parent045cc22baeb7f12dcb0022b79a1984d86e922870 (diff)
Add 'libosmocore/' from commit '045cc22baeb7f12dcb0022b79a1984d86e922870'openbsc/0.9.00.9.0
git-subtree-dir: libosmocore git-subtree-mainline: e164d29e7f6c86d1f6f047bbf58159e46a11425f git-subtree-split: 045cc22baeb7f12dcb0022b79a1984d86e922870
Diffstat (limited to 'libosmocore/src/Makefile.am')
-rw-r--r--libosmocore/src/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/libosmocore/src/Makefile.am b/libosmocore/src/Makefile.am
new file mode 100644
index 000000000..f0effa2ea
--- /dev/null
+++ b/libosmocore/src/Makefile.am
@@ -0,0 +1,16 @@
+# This is _NOT_ the library release version, it's an API version.
+# Please read Chapter 6 "Library interface versions" of the libtool documentation before making any modification
+LIBVERSION=0:0:0
+
+INCLUDES = $(all_includes) -I$(top_srcdir)/include
+AM_CFLAGS = -fPIC -Wall
+
+lib_LTLIBRARIES = libosmocore.la
+
+libosmocore_la_SOURCES = timer.c select.c signal.c msgb.c rxlev_stat.c \
+ tlv_parser.c bitvec.c comp128.c gsm_utils.c statistics.c \
+ write_queue.c utils.c rsl.c gsm48.c gsm48_ie.c
+
+if ENABLE_TALLOC
+libosmocore_la_SOURCES += talloc.c
+endif