aboutsummaryrefslogtreecommitdiffstats
path: root/libosmocore/include/osmocore/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2010-03-22 22:25:13 +0800
committerHarald Welte <laforge@gnumonks.org>2010-03-22 22:25:13 +0800
commit351ec2a1784fbdb2ce688f50a9134532f3bf0723 (patch)
treed599030f3ffb4e563b73f5ede9a8e80fc1bc048f /libosmocore/include/osmocore/Makefile.am
parente164d29e7f6c86d1f6f047bbf58159e46a11425f (diff)
parent045cc22baeb7f12dcb0022b79a1984d86e922870 (diff)
Add 'libosmocore/' from commit '045cc22baeb7f12dcb0022b79a1984d86e922870'openbsc/0.9.00.9.0
git-subtree-dir: libosmocore git-subtree-mainline: e164d29e7f6c86d1f6f047bbf58159e46a11425f git-subtree-split: 045cc22baeb7f12dcb0022b79a1984d86e922870
Diffstat (limited to 'libosmocore/include/osmocore/Makefile.am')
-rw-r--r--libosmocore/include/osmocore/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/libosmocore/include/osmocore/Makefile.am b/libosmocore/include/osmocore/Makefile.am
new file mode 100644
index 000000000..fb4f089b7
--- /dev/null
+++ b/libosmocore/include/osmocore/Makefile.am
@@ -0,0 +1,12 @@
+osmocore_HEADERS = signal.h linuxlist.h timer.h select.h msgb.h \
+ tlv.h bitvec.h comp128.h statistics.h gsm_utils.h utils.h \
+ gsmtap.h write_queue.h rsl.h gsm48.h rxlev_stat.h mncc.h \
+ gsm48_ie.h
+
+if ENABLE_TALLOC
+osmocore_HEADERS += talloc.h
+endif
+
+osmocoredir = $(includedir)/osmocore
+
+SUBDIRS = protocol