aboutsummaryrefslogtreecommitdiffstats
path: root/libosmocore/configure.in
diff options
context:
space:
mode:
authorHarald Welte <laforge@netfilter.org>2010-02-20 16:24:02 +0100
committerHarald Welte <laforge@netfilter.org>2010-02-20 16:27:23 +0100
commitdfe6c7d910edbba238751d0cfddbb627bb08ef54 (patch)
treec4836091b0d65187ee50c52060d51117b21ac873 /libosmocore/configure.in
parent9442c1b9bad3426ece07edc7fa2dca7464fc302a (diff)
split 'libosmocore' from openbsc codebase
This library is intended to collect all generic/common funcitionality of all Osmocom.org projects, including OpenBSC but also OsmocomBB The library currently includes the following modules: bitvec, comp128, gsm_utils, msgb, select, signal, statistics, talloc, timer, tlv_parse, linuxlist msgb allocation error debugging had to be temporarily disabled as it depends on 'debug.c' functionality which at the moment remains in OpenBSC
Diffstat (limited to 'libosmocore/configure.in')
-rw-r--r--libosmocore/configure.in37
1 files changed, 37 insertions, 0 deletions
diff --git a/libosmocore/configure.in b/libosmocore/configure.in
new file mode 100644
index 000000000..8c0fe6727
--- /dev/null
+++ b/libosmocore/configure.in
@@ -0,0 +1,37 @@
+AC_INIT
+
+AM_INIT_AUTOMAKE(libosmocore, 0.0alpha1)
+
+dnl kernel style compile messages
+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+
+dnl checks for programs
+AC_PROG_MAKE_SET
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_RANLIB
+AC_PROG_LIBTOOL
+
+dnl checks for header files
+AC_HEADER_STDC
+
+# The following test is taken from WebKit's webkit.m4
+saved_CFLAGS="$CFLAGS"
+CFLAGS="$CFLAGS -fvisibility=hidden "
+AC_MSG_CHECKING([if ${CC} supports -fvisibility=hidden])
+AC_COMPILE_IFELSE([char foo;],
+ [ AC_MSG_RESULT([yes])
+ SYMBOL_VISIBILITY="-fvisibility=hidden"],
+ AC_MSG_RESULT([no]))
+CFLAGS="$saved_CFLAGS"
+AC_SUBST(SYMBOL_VISIBILITY)
+
+dnl Generate the output
+AM_CONFIG_HEADER(config.h)
+
+AC_OUTPUT(
+ libosmocore.pc
+ include/osmocore/Makefile
+ include/Makefile
+ src/Makefile
+ Makefile)