aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorOliver Smith <osmith@sysmocom.de>2019-05-22 13:58:13 +0200
committerOliver Smith <osmith@sysmocom.de>2019-05-29 12:14:20 +0200
commiteb3a8556be96ab0155db07d0ac0fe40065666705 (patch)
tree96d02c1f9cf473727ed591ef22d755680c62fa6f /debian
parent1825ab5bae0b044bb6497200b5039284162d402e (diff)
debian: create -doc subpackage with pdf manuals
I have verified, that the resulting debian packages build in my own OBS namespace (see the -doc packages): https://download.opensuse.org/repositories/home:/osmith42/Debian_9.0/all/ https://build.opensuse.org/project/show/home:osmith42 Depends: Ib7251cca9116151e473798879375cd5eb48ff3ad (osmo-ci) Related: OS#3899 Change-Id: I9c09a0cb5c65fa2e2cd9817edb4656b2a1a35bb9
Diffstat (limited to 'debian')
-rw-r--r--debian/control12
-rw-r--r--debian/osmo-sgsn-doc.install1
-rwxr-xr-xdebian/rules6
3 files changed, 17 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index 9594a0841..9ad95a126 100644
--- a/debian/control
+++ b/debian/control
@@ -20,7 +20,8 @@ Build-Depends: debhelper (>=9),
libosmo-sccp-dev,
libosmo-sigtran-dev,
libosmo-netif-dev,
- libosmo-gsup-client-dev
+ libosmo-gsup-client-dev,
+ osmo-gsm-manuals-dev
Standards-Version: 3.9.8
Vcs-Git: git://git.osmocom.org/osmo-sgsn.git
Vcs-Browser: https://git.osmocom.org/osmo-sgsn
@@ -67,3 +68,12 @@ Section: debug
Priority: extra
Depends: osmo-gbproxy (= ${binary:Version}), ${misc:Depends}
Description: Debug symbols for Osmocom GPRS Gb Interface Proxy
+
+Package: osmo-sgsn-doc
+Architecture: all
+Section: doc
+Priority: optional
+Depends: ${misc:Depends}
+Description: ${misc:Package} PDF documentation
+ Various manuals: user manual, VTY reference manual and/or
+ protocol/interface manuals.
diff --git a/debian/osmo-sgsn-doc.install b/debian/osmo-sgsn-doc.install
new file mode 100644
index 000000000..bdc6a9922
--- /dev/null
+++ b/debian/osmo-sgsn-doc.install
@@ -0,0 +1 @@
+usr/share/doc/osmo-sgsn-doc/*.pdf
diff --git a/debian/rules b/debian/rules
index af6b5b6e4..cfd692a48 100755
--- a/debian/rules
+++ b/debian/rules
@@ -46,7 +46,7 @@
# debmake generated override targets
# Set options for ./configure
-CONFIGURE_FLAGS += --enable-iu --with-systemdsystemunitdir=/lib/systemd/system
+CONFIGURE_FLAGS += --enable-iu --with-systemdsystemunitdir=/lib/systemd/system --enable-manuals
override_dh_auto_configure:
dh_auto_configure -- $(CONFIGURE_FLAGS)
#
@@ -63,3 +63,7 @@ override_dh_strip:
# Print test results in case of a failure
override_dh_auto_test:
dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)
+
+# Don't create .pdf.gz files (barely saves space and they can't be opened directly by most pdf readers)
+override_dh_compress:
+ dh_compress -X.pdf