aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorMax <msuraev@sysmocom.de>2016-12-19 18:41:42 +0100
committerHarald Welte <laforge@gnumonks.org>2016-12-21 10:31:21 +0000
commit5fa8b083cc270fd30ab5526cd40683afd3035931 (patch)
treebc673c37965d6508a66d0882d1e9f9e7ba9e6c87 /debian/rules
parent549ebc7d6c001b9ce134c7462f621335dbf671b9 (diff)
Integrate Debian packaging changes
debian/control: * restructure to make it easier to incorporate further changes * update package descriptions * update project URL debian/rules: * use proper hardening syntax * restructure to make it easier to incorporate further changes * remove useless comment debian/compat: update compatibility version debian/coryright: update to match Debian format Change-Id: I49cc9239b15dc77d782914ca2547e601d049acdc Related: OS#1694
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 2 insertions, 12 deletions
diff --git a/debian/rules b/debian/rules
index ee632a2b9..4e187a6cf 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,14 +1,4 @@
#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-#
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-#
-# Modified to make a template file for a multi-binary package with separated
-# build-arch and build-indep targets by Bill Allombert 2001
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
@@ -17,10 +7,10 @@ DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
-export DEB_BUILD_HARDENING=1
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
%:
- dh --sourcedirectory=openbsc --with autoreconf $@
+ dh $@ --sourcedirectory=openbsc --with autoreconf
# This is needed for debian stable (squeeze)
override_dh_autoreconf: