aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2009-06-08 10:32:39 +0000
committerHolger Freyther <zecke@selfish.org>2009-06-08 10:32:39 +0000
commitc7aa3c4f799dfd847ebfecb752ededa9d2f8ed1f (patch)
treea11101e258ede55333d2e7a77f7531e363bce33c /Makefile.am
parentb424ecb2477026ae3896e12dd1244b5bca3a40ef (diff)
pkg-config: Create and install a pkg-config file
Let automake create the openbsc.pc and then install it into the pkg-config directory of ${libdir}. This is done in preparation for the public API that will be added soon. The advertised include directory will be ${incluedir}/openbsc-1.0 to follow userspace practive from glib/gtk/cairo/freetype2 and many more.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1ba06046d..deaba0fa1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,5 +3,8 @@ AUTOMAKE_OPTIONS = foreign dist-bzip2 1.6
INCLUDES = $(all_includes) -I$(top_srcdir)/include
SUBDIRS = include src tests
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = openbsc.pc
+
#dist-hook:
# rm -rf `find $(distdir) -name .svn`