aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2022-06-29 11:45:09 +0200
committerPau Espin Pedrol <pespin@sysmocom.de>2022-06-29 11:45:09 +0200
commit328ed940403db52dccc8b54bfd35eaa332796419 (patch)
treed889e6273281c7b331728331a09b3c46cdd45a1f
parentc230f0c28322fe36801ff14e77b20bd4835d4388 (diff)
Bump version: 1.8.0.9-c230-dirty → 1.9.01.9.0
-rw-r--r--configure.ac22
-rw-r--r--contrib/osmo-sgsn.spec.in22
-rw-r--r--debian/changelog23
-rw-r--r--debian/control18
4 files changed, 54 insertions, 31 deletions
diff --git a/configure.ac b/configure.ac
index 53517863..caa66d38 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,23 +45,23 @@ AC_SEARCH_LIBS([dlsym], [dl dld], [LIBRARY_DLSYM="$LIBS";LIBS=""])
AC_SUBST(LIBRARY_DLSYM)
-PKG_CHECK_MODULES(LIBOSMOCORE, libosmocore >= 1.6.0)
-PKG_CHECK_MODULES(LIBOSMOVTY, libosmovty >= 1.6.0)
-PKG_CHECK_MODULES(LIBOSMOCTRL, libosmoctrl >= 1.6.0)
-PKG_CHECK_MODULES(LIBOSMOGSM, libosmogsm >= 1.6.0)
-PKG_CHECK_MODULES(LIBOSMOGB, libosmogb >= 1.6.0)
-PKG_CHECK_MODULES(LIBOSMOABIS, libosmoabis >= 1.2.0)
-PKG_CHECK_MODULES(LIBOSMONETIF, libosmo-netif >= 1.1.0)
-PKG_CHECK_MODULES(LIBOSMOGSUPCLIENT, libosmo-gsup-client >= 1.4.0)
-PKG_CHECK_MODULES(LIBGTP, libgtp >= 1.8.0)
+PKG_CHECK_MODULES(LIBOSMOCORE, libosmocore >= 1.7.0)
+PKG_CHECK_MODULES(LIBOSMOVTY, libosmovty >= 1.7.0)
+PKG_CHECK_MODULES(LIBOSMOCTRL, libosmoctrl >= 1.7.0)
+PKG_CHECK_MODULES(LIBOSMOGSM, libosmogsm >= 1.7.0)
+PKG_CHECK_MODULES(LIBOSMOGB, libosmogb >= 1.7.0)
+PKG_CHECK_MODULES(LIBOSMOABIS, libosmoabis >= 1.3.0)
+PKG_CHECK_MODULES(LIBOSMONETIF, libosmo-netif >= 1.2.0)
+PKG_CHECK_MODULES(LIBOSMOGSUPCLIENT, libosmo-gsup-client >= 1.5.0)
+PKG_CHECK_MODULES(LIBGTP, libgtp >= 1.9.0)
# Enable/disable 3G aka IuPS + IuCS support?
AC_ARG_ENABLE([iu], [AS_HELP_STRING([--enable-iu], [Build 3G support, aka IuPS and IuCS interfaces])],
[osmo_ac_iu="$enableval"],[osmo_ac_iu="no"])
if test "x$osmo_ac_iu" = "xyes" ; then
- PKG_CHECK_MODULES(LIBOSMOSIGTRAN, libosmo-sigtran >= 1.5.0)
+ PKG_CHECK_MODULES(LIBOSMOSIGTRAN, libosmo-sigtran >= 1.6.0)
PKG_CHECK_MODULES(LIBASN1C, libasn1c >= 0.9.30)
- PKG_CHECK_MODULES(LIBOSMORANAP, libosmo-ranap >= 0.8.0)
+ PKG_CHECK_MODULES(LIBOSMORANAP, libosmo-ranap >= 1.3.0)
AC_DEFINE(BUILD_IU, 1, [Define if we want to build IuPS and IuCS interfaces support])
fi
AM_CONDITIONAL(BUILD_IU, test "x$osmo_ac_iu" = "xyes")
diff --git a/contrib/osmo-sgsn.spec.in b/contrib/osmo-sgsn.spec.in
index daedf06b..bc74688d 100644
--- a/contrib/osmo-sgsn.spec.in
+++ b/contrib/osmo-sgsn.spec.in
@@ -34,20 +34,20 @@ BuildRequires: systemd-rpm-macros
%endif
BuildRequires: pkgconfig(libcares)
BuildRequires: pkgconfig(libcrypto) >= 0.9.5
-BuildRequires: pkgconfig(libgtp) >= 1.8.0
-BuildRequires: pkgconfig(libosmo-gsup-client) >= 1.4.0
-BuildRequires: pkgconfig(libosmo-netif) >= 1.1.0
-BuildRequires: pkgconfig(libosmoabis) >= 1.2.0
-BuildRequires: pkgconfig(libosmocore) >= 1.6.0
-BuildRequires: pkgconfig(libosmoctrl) >= 1.6.0
-BuildRequires: pkgconfig(libosmogb) >= 1.6.0
-BuildRequires: pkgconfig(libosmogsm) >= 1.6.0
-BuildRequires: pkgconfig(libosmovty) >= 1.6.0
+BuildRequires: pkgconfig(libgtp) >= 1.9.0
+BuildRequires: pkgconfig(libosmo-gsup-client) >= 1.5.0
+BuildRequires: pkgconfig(libosmo-netif) >= 1.2.0
+BuildRequires: pkgconfig(libosmoabis) >= 1.3.0
+BuildRequires: pkgconfig(libosmocore) >= 1.7.0
+BuildRequires: pkgconfig(libosmoctrl) >= 1.7.0
+BuildRequires: pkgconfig(libosmogb) >= 1.7.0
+BuildRequires: pkgconfig(libosmogsm) >= 1.7.0
+BuildRequires: pkgconfig(libosmovty) >= 1.7.0
%{?systemd_requires}
%if %{with_iu}
BuildRequires: pkgconfig(libasn1c)
-BuildRequires: pkgconfig(libosmo-ranap) >= 0.8.0
-BuildRequires: pkgconfig(libosmo-sigtran) >= 1.5.0
+BuildRequires: pkgconfig(libosmo-ranap) >= 1.3.0
+BuildRequires: pkgconfig(libosmo-sigtran) >= 1.6.0
%endif
%description
diff --git a/debian/changelog b/debian/changelog
index e1706df9..b6952509 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,26 @@
+osmo-sgsn (1.9.0) unstable; urgency=medium
+
+ [ Oliver Smith ]
+ * llme_free: clean up related sndcp
+ * treewide: remove FSF address
+
+ [ Pau Espin Pedrol ]
+ * Drop unneeded ax_check_compile_flag.m4
+ * Revert "sgsn: Handle different levels of QoS"
+
+ [ Neels Hofmeyr ]
+ * s/cipher_support_mask/gea_encryption_mask
+ * Iu: add UEA encryption
+
+ [ Vadim Yanitskiy ]
+ * tests: use 'check_PROGRAMS' instead of 'noinst_PROGRAMS'
+
+ [ Harald Welte ]
+ * update git URLs (git -> https; gitea)
+ * README: Major update
+
+ -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 29 Jun 2022 11:45:08 +0200
+
osmo-sgsn (1.8.0) unstable; urgency=medium
[ Harald Welte ]
diff --git a/debian/control b/debian/control
index 73282bf9..650e9bea 100644
--- a/debian/control
+++ b/debian/control
@@ -11,16 +11,16 @@ Build-Depends: debhelper (>=9),
pkg-config,
libtalloc-dev,
libc-ares-dev,
- libgtp-dev (>= 1.8.0),
- libosmocore-dev (>= 1.6.0),
- libosmo-abis-dev (>= 1.2.0),
- libosmo-netif-dev (>= 1.1.0),
- libosmo-gsup-client-dev (>= 1.4.0),
+ libgtp-dev (>= 1.9.0),
+ libosmocore-dev (>= 1.7.0),
+ libosmo-abis-dev (>= 1.3.0),
+ libosmo-netif-dev (>= 1.2.0),
+ libosmo-gsup-client-dev (>= 1.5.0),
libasn1c-dev (>= 0.9.30),
- libosmo-ranap-dev (>= 0.8.0),
- libosmo-sigtran-dev (>= 1.5.0),
- libosmo-sccp-dev (>= 1.5.0),
- osmo-gsm-manuals-dev (>= 1.2.0)
+ libosmo-ranap-dev (>= 1.3.0),
+ libosmo-sigtran-dev (>= 1.6.0),
+ libosmo-sccp-dev (>= 1.6.0),
+ osmo-gsm-manuals-dev (>= 1.3.0)
Standards-Version: 3.9.8
Vcs-Git: https://gitea.osmocom.org/cellular-infrastructure/osmo-sgsn
Vcs-Browser: https://gitea.osmocom.org/cellular-infrastructure/osmo-sgsn