aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 00000000..7581ea95
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,16 @@
+
+
+
+# Python testing
+if ENABLE_VTY_TESTS
+python-tests: $(BUILT_SOURCES)
+ osmotestvty.py -p $(abs_top_srcdir) -w $(abs_top_builddir) -v
+ osmotestconfig.py -p $(abs_top_srcdir) -w $(abs_top_builddir) -v
+
+else
+python-tests: $(BUILT_SOURCES)
+ @echo "Not running python-based tests (determined at configure-time)"
+endif
+
+check-local: $(BUILT_SOURCES)
+ $(MAKE) $(AM_MAKEFLAGS) python-tests