aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index a752067b..415fb4d4 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,6 +1,6 @@
AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGB_CFLAGS) $(LIBOSMOGSM_CFLAGS) -I$(top_srcdir)/src/
-check_PROGRAMS = rlcmac/RLCMACTest alloc/AllocTest
+check_PROGRAMS = rlcmac/RLCMACTest alloc/AllocTest tbf/TbfTest
noinst_PROGRAMS = emu/pcu_emu
rlcmac_RLCMACTest_SOURCES = rlcmac/RLCMACTest.cpp
@@ -17,6 +17,14 @@ alloc_AllocTest_LDADD = \
$(LIBOSMOCORE_LIBS) \
$(COMMON_LA)
+tbf_TbfTest_SOURCES = tbf/TbfTest.cpp
+tbf_TbfTest_LDADD = \
+ $(LIBOSMOGB_LIBS) \
+ $(LIBOSMOGSM_LIBS) \
+ $(LIBOSMOCORE_LIBS) \
+ $(COMMON_LA) \
+ $(top_builddir)/src/libgprs.la
+
emu_pcu_emu_SOURCES = emu/pcu_emu.cpp emu/test_replay_gprs_attach.cpp \
emu/openbsc_clone.c emu/openbsc_clone.h emu/gprs_tests.h \
emu/test_pdp_activation.cpp
@@ -49,7 +57,8 @@ $(srcdir)/package.m4: $(top_srcdir)/configure.ac
EXTRA_DIST = \
testsuite.at $(srcdir)/package.m4 $(TESTSUITE) \
rlcmac/RLCMACTest.ok rlcmac/RLCMACTest.err \
- alloc/AllocTest.ok alloc/AllocTest.err
+ alloc/AllocTest.ok alloc/AllocTest.err \
+ tbf/TbfTest.ok tbf/TbfTest.err
DISTCLEANFILES = atconfig