aboutsummaryrefslogtreecommitdiffstats
path: root/debian/changelog
diff options
context:
space:
mode:
Diffstat (limited to 'debian/changelog')
-rw-r--r--debian/changelog663
1 files changed, 663 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index dc42c0c1..3e50d665 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,666 @@
+osmo-pcu (1.4.0) unstable; urgency=medium
+
+ [ Pau Espin Pedrol ]
+ * tbf: Log poll timeout reason
+
+ [ Vadim Yanitskiy ]
+ * pdch_ul_controller: migrate from fn_cmp() to gsm0502_fncmp()
+ * bts: bts_tfi_find_free(): fix -Wmaybe-uninitialized (false positive)
+
+ [ Oliver Smith ]
+ * systemd: remove RestartPreventExitStatus=1
+ * Revert "pdch_ul_controller: migrate from fn_cmp() to gsm0502_fncmp()"
+
+ [ Philipp Maier ]
+ * pcuif_proto: rename PCU_IF_FLAG_SYSMO to PCU_IF_FLAG_DIRECT_PHY
+ * pcuif_proto: drop support for PCUIF v10
+ * pcu_l1_if: signal BTS model via PCUIF
+ * gprs_rlcmac_sched: fix condition for generating dummy blocks on idle
+ * bts: rename struct member gen_idle_blocks to gen_idle_blocks_C0
+
+ [ Andreas Eversberg ]
+ * Increase RR scheduler priority to 20, to avoid dropped bursts
+ * Use uniform log format for default config files
+
+ [ Keith ]
+ * TBF status: Fix VTY output text
+
+ -- Oliver Smith <osmith@sysmocom.de> Tue, 12 Dec 2023 16:58:16 +0100
+
+osmo-pcu (1.3.1) unstable; urgency=medium
+
+ * tbf_dl_fsm: Fix assert hit due to EV_MAX_N3105 received in ST_RELEASING
+
+ -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 15 Sep 2023 11:33:44 +0200
+
+osmo-pcu (1.3.0) unstable; urgency=medium
+
+ [ Philipp Maier ]
+ * pcuif_proto: move gsm_pcu_if_e1_ccu_ind into right place
+ * pcu_l1_if.cpp: handle TLLI based IMMEDIATE ASSIGNMENT confirmation
+ * pcu_l1_if: move direct phy l1if functions to dedicated header file
+ * lc15/oc2g: fix function signature of l1if_open_pdch()
+ * osmo-bts-xyz: include pcu_l1_if_phy.h in phy in l1_if code
+ * en/decoding: fix deprecated include path
+ * pcu_l1_if: use only the term "direct PHY access"
+ * pcu_l1_if_phy: add header file for struct gsmtap_inst
+ * pcu_l1_if_phy: add new PHY API function to disconnect PDCH
+ * pcu_l1_if_phy: add new PHY API function to initialize PHY
+ * pcu_l1_if: cosmetic: remove whitespace after *
+ * pcu_l1_if_phy: support multiple BTS (in theory)
+ * bts: add IMMEDIATE ASSIGNMENT via PCH transmission
+ * support for Ericsson RBS E1 CCU
+ * pcu_l1_if: get rid of strange paging group calculation
+ * doc: add sample config to illustrate how to use an E1 CCU
+ * pcu_l1_if: do not copy IMSI when it is NULL
+ * Makefile.am: remove phy specific EXTRA_DIST variables
+ * doc: overview: put BTS and PCU on the same rank
+ * doc: Add details regarding BSC co-location
+ * pdch_ul_controller: log reserved frame numbers
+ * pcu_l1_if: cosmetic: reformat comment
+ * er_ccu_l1_if: use one ccu_desr per timeslot
+ * pcu_l1_if_phy: fix API function names
+ * pcu_l1_if: replace magic numbers with IMSI_DIGITS_FOR_PAGING
+ * gprs_rlcmac: also use PCU_IF_SAPI_PCH_DT for paging MAC blocks
+ * pcu_l1_if: use correct SAPI in PCUIF message PCU_IF_MSG_DATA_CNF_DT
+ * neigh_cache: make neigh_cache_lookup_entry static
+ * nacc_fsm: Add support for NACC with UTRAN and E-UTRAN cells
+ * nacc_fsm: fix uninitialized neigh_key variable
+ * pcuif_proto: rename tlli to msg_id
+ * bts: get rid of fn parameter in bts_rcv_imm_ass_cnf
+ * pcuif_proto: remove unnecessary members from gsm_pcu_if_data_cnf_dt
+ * pcuif_proto: get rid of _DT, _dt (Direct TLLI)
+ * pcuif_proto: add confirm flag to struct gsm_pcu_if_pch
+ * pcu_l1_if: add support for PCU_IF_SAPI_AGCH_2 for PCUIF v.11
+ * osmobts_sock: cosmetic: rename osmobts_sock.c to pcuif_sock.c
+ * pcuif_sock: improve log output (OsmoBTS/OsmoBSC)
+
+ [ Oliver Smith ]
+ * Run struct_endianness.py
+ * lc15bts.h: add missing extern keyword
+ * debian: set compat level to 10
+ * systemd: depend on networking-online.target
+
+ [ Pau Espin Pedrol ]
+ * tbf: Increase log level if polling requested in wrong TS
+ * tbf_ul_fm: Allow receiving event TBF_EV_MAX_N3105 in state RELEASING
+ * osmo_bts_sock.c: Call osmo_fd_unregister() before closing and changing bfd->fd
+ * Update libosmogsm deprecated include
+ * ms: Fix MS without PTMSI not freed immediatelly
+ * ms: Drop setting tlli during ms_alloc()
+ * tbf_dl: Avoid attempt scheduling DL ACK/NACK in TS != CTRL TS
+ * ms: Drop setting (egprs_)ms_class during bts_alloc_ms()
+ * bts: Rename bts_ms_by_{tlli,imsi} -> bts_get_ms_by_{tlli,imsi}
+ * ms: Merge ms_storage into bts.cpp
+ * ms: store in bts->ms_list during alloc/destroy of ms object
+ * Merge bts_alloc_ms() and ms_alloc()
+ * ms: Use osmo_use_count to track references
+ * ms: Make sure tbf!=NULL in ms_attach_{ul,dl}_tbf()
+ * ms: Make ms_{attach,detach}_tbf expectancies more robust
+ * ms: Log detaching tbf log line in proper place
+ * ms: Rewrite MS release lifecycle
+ * tbf: Store initial timestamp during constructor
+ * tbf: Move m_ctrs alloc to constructor
+ * tbf_ul: Move rate_ctr allocation to constructor
+ * tbf: Move enable_egprs() to constructor
+ * cosmetic: Fix indentation in comment
+ * ms: Hold a reference during ms_alloc
+ * dl_tbf: Set BandWidth timestamps to current time directly
+ * Add new log category 'ms'
+ * ms: Increase log level when scheduling release timer
+ * meas: Improve logging formatting
+ * ms: Get rid of ms->delay field
+ * ms: Rename field timer -> release_timer
+ * ms: Log MS active/idle state in 'show ms' VTY commands
+ * vty: Several improvements to 'show ms' output format
+ * alloc_algo: Pass a struct containing all req params
+ * alloc_algo: Move printing outside of update_ms_reserved_slots()
+ * Move out of alloc_algo code modifying the data model
+ * Move resource allocation outside of tbf allocation
+ * ms: Mark ms_reset() as static
+ * ms: Fix unsafe iterating freeing items in list
+ * cosmetic: ms: fix formatting of function comment
+ * tbf: Improve TBF name description in logs
+ * cosmetic: tbf_ul_ack_fsm: Clean up use of ul_tbf and tbf pointers
+ * Use always RFN when handling RACH indications
+ * Error trying to obtain FN from RFN if curr_fn not known
+ * bts: use RFN directly to calculate fn416
+ * encoding: pass RFN to write_immediate_assignment(_reject)()
+ * Derive FN from RFN once and cache it in struct rach_ind_params
+ * Use fn_valid() helper in pcu_rx_time_ind()
+ * Move call to bts_set_current_frame_number() earlier in the code path
+ * Use OSMO_UNLIKELY() in bts_rfn_to_fn()
+ * pcu_utils.h: Replace software based bitcount impl with gcc builtin
+ * Document pcu_lsb() function
+ * Log MS information in error message using usual MS API
+ * tbf_dl_fsm: Apply T3193 using FSM infrastructure instead of manually
+ * tbf_{ul,dl}_fsm: Remove unneeded asserts
+ * tbf_{ul,dl}_fsm: remove impossible dst state transitions
+ * Avoid using N3101 in DL TBFs
+ * Avoid using N3103 in DL TBFs
+ * Avoid using N3105 in UL TBFs
+ * tbf_dl_fsm: Remove T3169 references, simplify T3195 set up as consequence
+ * tbf_ul_fsm: Remove 3195 references, simplify T3169 set up as consequence
+ * Abort UL TBF PACCH Ass based on T3168
+ * Remove unused GPRS_RLCMAC_FLAG_TO_MASK
+ * Improve logging in bts_snd_dl_ass()
+ * tbf_dl_fsm: Fix wrong lchan specified in log line
+ * tbf_{ul,dl}_fsm: Abort on unexpected path
+ * tbf_{ul,dl}_fsm.c: Rearrange code/logs in mod_ass_type()
+ * Move GPRS_RLCMAC_FLAG_TO_DL_ACK from state_fsm to dl_tbf
+ * Move GPRS_RLCMAC_FLAG_DL_ACK from state_fsm to dl_tbf
+ * tests/tbf: Drop unneeded line re-setting CCCH ass type
+ * cosmetic: tbf_dl_fsm: Fix a couple comment typos
+ * Move call to bts_snd_dl_ass() from tbf_dl.cpp to tbf_dl_fsm.c
+ * Change several log lines to start with capital letter
+ * cosmetic: Improve comment
+ * Fix DL_TBF PACCH ass done on UL_TBF already scheduled to tx last PKT CTRL ACK
+ * bts: Use same default value for T3193 as set in osmo-bts/bsc
+ * Store T3192 value received from SI13, do some sanity checks
+ * tbf_dl_fsm: Drop impossible event
+ * cosmetic: tbf_fsm: Fix typo in comment
+ * pdch.cpp: Drop impossible code path
+ * Differentiate between T3192 and T3193
+ * ms_need_dl_tbf(): Fix state checks and document function
+ * tbf_ul: Avoid processing rx UL blocks for UL TBFs in RELEASING state
+ * tbf_ul_fsm: Delay moving ul_tbf to FLOW
+ * Avoid using UL TBF in RELEASE state to assign DL TBF over PACCH
+ * Avoid re-assigning DL TBF over PACCH upon duplicate FinalACKs received
+ * tbf_dl_fsm: Ignore DL_ACKNACK_MISS events in WAIT_{RELEASE,REUSE_TFI} states
+ * Reestore last LLC frames never completely acked when freeing DL TBF
+ * cosmetic: pdch.cpp: Drop wrong comment due to copy-paste error
+ * tbf_dl_fsm: Fix '{FLOW}: Event ASSIGN_PCUIF_CNF not permitted'
+ * pcuif: Log read() error cause
+ * gprs_ms: Constify variable in ms_is_reachable_for_dl_ass()
+ * gprs_ms: Update assert condition
+ * oc2g: Fix multiple definitions of arrays
+ * pcu_l1_if: Document tx_pch empty IMSI scenario
+ * gprs_rlc_ul_window: Make sure V(N) array is cleared during reset_state()
+ * Split rlc_{dl_,ul_,}window out of rlc.{h,cpp}
+ * gprs_rlc_ul_window: Mark received BSNs falling out of the V(N)/RBB when V(R) is raised
+ * cosmetic: mslot_class.h: Update spec reference
+ * cosmetic: Document foce_two_phase feature based on specs
+ * pcu_l1_if.cpp: Fix gsmtap not sent in PCU_IF_SAPI_PCH_DT
+ * vty: Allow modifying default msclass
+
+ [ Vadim Yanitskiy ]
+ * {src,tests}/Makefile.am: libraries shall not be in AM_LDFLAGS
+ * tests/Makefile.am: do not overwrite global LDFLAGS
+ * fix pcu_rx(): actually discard malformed container message
+ * tests: $(BUILT_SOURCES) is not defined, depend on osmo-pcu
+ * copyright: fix typo: sysmocom s/s.m.f.c./s.f.m.c./ GmbH
+
+ [ arehbein ]
+ * PCU interface: Log version when starting listener
+
+ [ Max ]
+ * gprs_rlcmac: convert from C++ to C
+ * ctrl: drop deprecated neighbor resolution interface
+
+ -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 12 Sep 2023 16:00:25 +0200
+
+osmo-pcu (1.2.0) unstable; urgency=medium
+
+ [ Vadim Yanitskiy ]
+ * encoding: fix an uninitialized field in gen_freq_params()
+ * neigh_cache: fix: properly convert from nanoseconds to microseconds
+ * tests/rlcmac: remove unused #includes
+ * tests/rlcmac: remove unused printSizeofRLCMAC()
+ * tests/rlcmac: make all test functions static
+ * tests/rlcmac: cosmetic: fix coding style in arrays
+ * tests/rlcmac: use ARRAY_SIZE macro
+ * tests: make target 'check-local' depend on 'atconfig'
+ * tests: target 'check-local' does not depend on BUILT_SOURCES
+ * Makefile.am: generate missing .version file
+ * Makefile.am: add 'git-version-gen' to EXTRA_DIST
+ * {ms,gprs_pcu}_talloc_destructor(): call osmo_timer_del() unconditionally
+ * {src,tests}/Makefile.am: $(COMMON_LA) is not definied
+ * fix pcu_l1if_tx_ptcch(): do not send empty blocks to GSMTAP
+ * Make linter happy: fix coding style issues
+ * bts_set_current_frame_number(): log expected TDMA FN
+ * bts: bts_snd_dl_ass(): clarify the meaning of last_rts_fn + 21216
+ * bts: bts_snd_dl_ass(): use GSM_TDMA_FN_SUM() macro
+ * Makefile.am: drop unneeded '-ldl -pthread' from AM_CXXFLAGS
+
+ [ Pau Espin Pedrol ]
+ * nacc_fsm: Fix uninitialized plmn.mnc_3_digits parsing CTRL neigh resolution cmd
+ * cosmetic: Add missing spacing between params
+ * Use GSM48_MT_RR_IMM_ASS instead of hardcoded 0x3f value
+ * Clarify use RR imm_ass msg fields
+ * bts_rcv_imm_ass_cnf(): Improve logging
+ * cosmetic: Update reference to func renamed in the past
+ * gprs_ms: Document functions setting/updating TLLI
+ * Call ms_store->get_ms() with GSM_RESERVED_TMSI instead of 0
+ * gprs_ms: Move creating string name of object to a function
+ * Move LLC enqueuing and retransmit timer to MS object
+ * tbf_ul_ack_fsm: Pass ul_tbf instead of generic tbf
+ * Rename tbf_alloc_dl_tbf() -> dl_tbf_alloc()
+ * tbf_dl: Make dl_tbf_alloc API available in C code
+ * Fix mess with struct tbf types passed to LOGPTBF macro
+ * Rename as_{dl,ul}_tbf -> tbf_as_{dl,ul}_tbf
+ * tbf_ul_ack_fsm: get ul_tbf base class only when needed
+ * use new {dl,ul}_tbf_as_tbf(_const) helper functions
+ * pdch: Use helper function tbf_as_ul_tbf()
+ * rcv_resource_request(): Validate expected message before MS lookup & allocation
+ * encoding: Use MT_PACKET_UPLINK_ASSIGNMENT define instead of hardcoded value
+ * rcv_resource_request(): Update meas before allocating and assigning new UL TBF
+ * Delay ImmAss(PCH, PktDlAss) if waiting for PKT_CTRL_ACK answering UL_ACK_NACK (FinACK=1)
+ * Refactor and clarify tbf->triger_ass() code
+ * Rename function tbf_dl_request_dl_ack() -> dl_tbf_request_dl_ack()
+ * Replace tbf->establish_dl_tbf_on_pacch() refactoring GprsMs functions
+ * ul_tbf: Define m_contention_resolution_done as bool
+ * tbf_fsm: Identify several events as Dl-TBF only
+ * Move UL allocation&assign functions to gprs_ms.c
+ * update_ms(): Set TLLI of new MS object before merge with old MS
+ * Join ms_merge_and_clear_ms() and ms_merge_old_ms()
+ * gprs_ms: Add comment warning the user that a ptr may be freed after call to func
+ * Rename tbf_alloc_ul_tbf -> ul_tbf_alloc
+ * Rework tbf::update_ms()
+ * tbf_fsm: Introduce new event TBF_EV_FIRST_UL_DATA_RECVD
+ * Avoid losing DL-TBF during MS merge
+ * tbf_fsm: Introduce new event to act upon contention resolution success
+ * tbf_ul: Assign DL-TBF if needed after UL-TBF has gone over contenion resolution
+ * Improve TBF logging
+ * Improve MS logging
+ * Disable logging fsm addresses
+ * tbf_fsm: Move tbf_fsm_state_chg macro to .c file
+ * tbf_fsm: Move osmo_fsm_inst fi out of struct tbf_fsm_ctx
+ * tbf: Drop unused function
+ * tbf: Add tbf_as_{ul,dl}_tbf_const func helpers
+ * Refactor tbf_is_tfi_assigned() to avoid accessing tbf->state_fsm
+ * Split tbf_fsm as tbf_{ul,dl}_fsm
+ * Convert gprs_debug.cpp to C
+ * pdch: Initial support Handling PktResReq with ID_TYPE=UL/DL_TFI
+ * pdch_ulc_get_node(): assert if ulc pointer is null
+ * Pass gprs_rlcmac_pdch to tbf_is_control_ts
+ * Pass pdch ptr to tbf_compute_priority
+ * encoding::write_immediate_assignment(): Constify tbf param
+ * tbf_ul_fsm_ctx: Properly define tbf backptr as ul_tbf
+ * tbf_dl_fsm_ctx: Properly define tbf backptr as dl_tbf
+ * Move control_ts explicit checks out of the scheduler implementation
+ * sched: Pass pdch to *_create_rlcmac_msg() functions
+ * Move first_common_ts from gprs_rlcmac_tbf to GprsMs
+ * Get rid of tbf->first_ts
+ * Refactor code related to DL-TBF upgrade to multislot
+ * Trigger PACCH assignment inside dl_tbf_upgrade_to_multislot()
+ * tbf_ul: Fix wrong struct type in field
+ * Refactor code rejecting UL-TBF upon rx of PktResourceReq
+ * bts: Adapt slot_mask to trx defined array size
+ * Convert ms_first_common_ts to struct gprs_rlcmac_pdch
+ * Rename gprs_rlcmac_ts_alloc.cpp -> alloc_algo.cpp & create own .h file
+ * pdch: Introduce APIs to print PDCH name
+ * tbf: Fix typo in define used
+ * Convert tbf->control_ts to be a gprs_rlcmac_pdch*
+ * tests/tbf: test_tbf_dl_llc_loss(): Fix wrong param passed and wrong expectancies
+ * Pass gprs_rlcmac_pdch to create_dl_acked_block()
+ * Pass gprc_rlcmac_pdch to tbf_check_polling
+ * Pass gprc_rlcmac_pdch to tbf_set_polling
+ * bts: Adapt trx check based on bts->trx[] defined array size
+ * tests/TbfTest: reproduce buggy corner case: MS with TBFs on 2 TRXs
+ * Avoid moving DL-TBF from old_msg to new_ms during ms_merge
+ * llc: Mark llc_is_user_data_frame() as static
+ * llc: Refactor code checking if PDU expired while dequeueing
+ * llc: remove unused reference to msgb address
+ * cosmetic: Remove unneeded curly braces
+ * Mark several fsm related internal symbols as static
+ * rlc.h: Fix typo in param name
+
+ [ Max ]
+ * Set working directory in systemd service file
+ * Update and document realtime scheduling priority in service file
+ * cosmetic: drop unused field from struct pdch_ulc
+ * cosmetic: drop duplicated comment
+ * constify pdch_ulc_get_next_free_fn() parameter
+
+ [ Philipp Maier ]
+ * pcuif_proto: cosmetic: rename struct member "h" to "hopping"
+ * pcuif_proto: cosmetic: rename gsm_pcu_if_info_ts to gsm_pcu_if_info_trx_ts
+ * pcuif_proto: use define constant to specify nax number of trx
+ * bts: refuse to set invalid frame numbers
+ * bts: use GSM_TDMA_FN_ macros and uint32_t in bts_rfn_to_fn
+ * bts: log FN jump delta in bts_set_current_frame_number()
+ * pcuif_proto: add indication to communicate E1 parameters
+ * pcu_l1_if: cosmetic: use sizeof instead of constants
+ * pcu_l1_if: ignore frame numbers that exceed the valid range
+ * pcuif_proto: rename PCU_IF_SAPI_AGCH_DT to PCU_IF_SAPI_PCH_DT
+
+ [ Harald Welte ]
+ * update horribly outdated copyright statement on VTY
+
+ [ arehbein ]
+ * osmo-pcu: Transition to use of 'telnet_init_default'
+
+ -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 07 Feb 2023 17:10:40 +0100
+
+osmo-pcu (1.1.0) unstable; urgency=medium
+
+ [ Oliver Smith ]
+ * treewide: remove FSF address
+
+ [ Pau Espin Pedrol ]
+ * Fix assert hit if connecting to SGSN fails
+ * llc: Convert to C: s/m_//g
+ * llc: Convert to C
+ * llc: Move static functions below related object
+ * ms: validate codel enabled against proper define
+ * ms: Remove unneeded bts!=NULL check
+ * gprs_ms_storage: MS always has non NULL ms->bts
+ * llc: schedule frames to MS based on SAPI priority
+ * pdch is_enabled: Use API getter instead of accessing field directly
+ * llc_queue: Refactor to handle codel_state per prio queue internally
+ * tests/llc: Add test_llc_meta_pdu_life_expire
+ * tests/llc: Add test_llc_codel
+ * gprs_ms: Use osmo_timer_setup() API
+ * gprs_ms_storage: Use bts_stat_item_inc/dec APIs
+ * tests/tbf: Set up pcu timers in prepare_pcu()
+ * gprs_pcu: Explicitly free all bts objects in list before freeing pcu
+ * bts: Call gprs_bssgp_destroy() in destructor
+ * TbfTest: Reset MS timeout to 0 in test_tbf_dl_llc_loss()
+ * gprs_ms_stoage: Release all MS in ms_storage cleanup()
+
+ [ Harald Welte ]
+ * update git URLs (git -> https; gitea)
+
+ -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 29 Jun 2022 09:48:53 +0200
+
+osmo-pcu (1.0.0) unstable; urgency=medium
+
+ [ Pau Espin Pedrol ]
+ * Support uplink multi-slot allocations
+ * tbf: Log timeslot allocation failure
+ * bts: Count TBF TS allocation failure
+ * pdch: Standarize and improve logging
+ * tbf: Improve logging when TBF being allocated or no TBF avail
+ * Remove uneeded ms param from alloc_algorithm_func_t func
+ * bts: Add new stats to detect TBF allocation failure reasons
+ * llc: use memset to fill llc dummy frame padding
+ * tbd_dl: Don't re-initialize class field twice
+ * tbf: log keep_open condition status
+ * tbf_dl: Fix m_last_dl_drained_fn not set under some conditions
+ * tbf_dl: fix FBI not set upon X2031 = 0
+ * ms: clarify delayed MS release process related code and logging
+ * gprs_ms: Use standarized logging on more messages
+ * sched: sched_select_ctrl_msg(): Clean up param list and improve logging
+ * sched: sched_select_downlink(): Clean up param list and improve logging
+ * TODO-RELEASE: document requirement of master libosmocore
+ * tbf: Log N310* counter increments
+ * pdch: Silently ignore DATA.ind with len=0
+ * direct_phy: Support submitting DATA.ind with len=0 to upper layers
+ * pcu_utils.h: Fix trailing whitespace
+ * Track TDMA clock with DATA.ind instead of TIME.ind
+ * Introduce init() APIs for PDCH and TRX objects
+ * tests: rlcmac: Fix C vs C++ linkage of extern symbol
+ * pdch.h: Drop uneeded include bts.h
+ * Improve DATA.ind logging
+ * Improve logging in DATA.req and ACT.req
+ * tbf: Fix wrong variable printed in log
+ * pdch: Log FN when decoding UL Ctrl block
+ * Add new PDCH UL Controller, drop SBAllocator class
+ * Replace PollController with newly added PDCH UL Controller
+ * sched: Use new PDCH UL Controller
+ * bts: Detect FN jumps
+ * cosmetic: tests/Makefile.am: Split content into several lines
+ * tests: Introduce unit tests for PDCH UL Controller
+ * tests: ulc: Show current bug with FN wrap around
+ * ulc: Fix FN store order upon wrap around
+ * sysmo: fix wrong FN jumps in rx RA.ind
+ * direct_phy: Fix condition dropping rx DATA.ind payload in in
+ * Fix: left shift cannot be repesented in type int
+ * sched: Fix scheduling UL TBF not matching conditions
+ * sched: Simplify usf selection code
+ * Set matching USF if available when polling a UL TBF
+ * pdch: Add mising pdch_ulc_release_node in Rx Cell Change Notif
+ * pdch_ulc: Create helper API pdch_ulc_release_node
+ * Track scheduled UL blocks through USF
+ * Properly implement N3101
+ * sba: Document AGCH_START_OFFSET after some experimental tests
+ * pdch_ulc: Optimize rbtree FN search
+ * Pick unreserved UL FN when allocating an SBA
+ * pdch_ulc: Support picking RRBP other than N+13
+ * Drop unused function tbf_check()
+ * pdch_ulc: Store TBF poll reason
+ * tbf: Get rid of unneeded poll_scheduled()
+ * tbf: Allow multiple concurrent polls
+ * Remove unneeded poll_state check
+ * tbf: get rid of poll_state completely
+ * Get rid of param 'poll' with constant value
+ * tbf: Get rid of attribute poll_fn
+ * tbf: Get rid of attribute poll_ts
+ * RIM: Improve logging
+ * sba: Drop unused function find_sba_rts
+ * pdch: rcv_resource_request: Improve robustness
+ * pdch: tbf_by_tfi(): Allow returning TBFs in state RELEASING
+ * Stop abusing T3169
+ * Make use of T3142 received from BTS
+ * Use negative numbers for non-spec osmo-specific timers
+ * ul_tbf: Clean up handle_tbf_reject()
+ * Make WaitIndication T3172 configurable
+ * sched: Simplify else-if condition
+ * Clarify, document Assignment related timers
+ * doc/tbf.txt: Update and improve some information
+ * bts: constify arg in func bts_ms_store()
+ * sched: Rename func to describe its used only for RLCMAC CTRL blocks
+ * rim: Constify param in func
+ * Simplify helper function tbf_select_slot_set()
+ * alloc_algorithm_b: Rearrange variable initialization
+ * Rename function s/tbf_alloc_ul/tbf_alloc_ul_pacch/
+ * Split ul_tbf alloc on CCCH into new function
+ * Implement T3141
+ * tbf_ul: Use is_tlli_valid() API
+ * Tx ul ack/nack: Avoid sending invalid/unknown TLLI
+ * encoding: Use gsm48_ta_is_valid() API
+ * encoding: Encode TA in UL ACK/NACK if available
+ * sched: Clean up helper function and improve logging
+ * Drop existing tbf->ms() check condition
+ * ul_tbf: Simplify function rcv_data_block_acknowledged
+ * ul_tbf: Fix accessing zeroed block when checking if transfer is complete
+ * sched: Clean up param passing and improve logging
+ * pdch: Use llist_first_entry() API
+ * RIM: Refactor Rx path to decode stack in proper order
+ * Clean false positive in newer GCC version checking guard of else clause
+ * Use LOGPDCH macro in bts_add_paging()
+ * Optimize PAGING-CS PDCH set selection when target MS is known
+ * bts: Use ms_store when calculating set of target PDCHs for Pkt Paging Request
+ * tbf: Log error path in setup() failing to assign control TS
+ * Move TBF list from BTS to the TRX structure
+ * MsTest: Set up tbf talloc destructor
+ * tbf: Move existing tbf_state implementation to osmo_fsm
+ * cosmetic: Fix typo s/TIMSI/TMSI/
+ * gsm_rlcmac.c: Fix arg list of 2 callbacks
+ * csn1: Implement CSN_CALLBACK type in encoder
+ * bts: Fix typo in field name
+ * Use new stat item/ctr getter APIs
+ * pdch: Log pdch_ulc reason upon rx of pkt ctrl ack
+ * pcuif: Support receiving System Information 2
+ * pdch: Fix null MS access gprs_rlcmac_pdch::rcv_control_ack
+ * pcuif_proto.h: Add new container message
+ * Support proto IPAC_PROTO_EXT_PCU BSC<->PCU
+ * pdch: Fix heap-use-after-free in pdch->ulc
+ * Make gcc 11.1.0 false positivies happy
+ * tbf: Drop impossible paths in create_dl_ass()
+ * tests/tbf: Fix null pointer access if slowly stepping with gdb
+ * Revert "coverity: fix null deref from recent UL TBF leak fix"
+ * Revert "fix: handle NULL return of as_dl_tbf() and as_ul_tbf()"
+ * Revert "Revert "Stop abusing T3169""
+ * Move NULL and ASSIGN tbf_state transition to tbf_fsm
+ * Move FLOW tbf_state transition to tbf_fsm.
+ * tests: tbf: Fix dl_tbf polled for data without being in FLOW state
+ * Move FINISHED tbf_state transition to tbf_fsm
+ * Move WAIT_RELEASE tbf_state transition to tbf_fsm
+ * Move RELEASING tbf_state transition to tbf_fsm
+ * Move T3169 and T3195 to tbf_fsm
+ * Drop duplicate log line
+ * Put dl_tbf::cleanup into destructor
+ * Drop logging last mas report before freeing TBF
+ * Remove duplicate call to gprs_rlcmac_lost_rep
+ * Move rate_ctr free to tbf subclass destructor
+ * Get rid of tbf_dl:abort()
+ * tbf_free: Get rid of uneeded tbf_state transition
+ * Replace ul_ass_state with osmocom FSM
+ * tbf: Reimplement rlcmac_diag() and make it available from C
+ * tbf: Drop unuseful flag GPRS_RLCMAC_FLAG_TO_UL_ASS
+ * replace dl_ass_state with osmocom FSM
+ * tbf: Drop unuseful flag GPRS_RLCMAC_FLAG_TO_DL_ASS
+ * tbf: Drop unuseful flag GPRS_RLCMAC_FLAG_UL_DATA
+ * Move timer X2001 to tbf_fsm
+ * Get rid of lots of code only used by tests
+ * tbf: Merge handle_ack_nack() into rcvd_dl_ack()
+ * Fix typos in comments documenting fsm st chg macro
+ * tbf: Use type bool for upgrade_to_multislot
+ * Move timer X2002 to tbf_fsm
+ * tbf_dl: Clarify requirements for DL ACK/NACK
+ * tbf.h: Improve documentation on several flags
+ * Move tbf ul_ack_state to osmocom FSM
+ * Simplify tbf::set_polling()
+ * tbf: Move T3193 to tbf_state FSM
+ * fix typo 's/dowlink/downlink/g'
+ * cosmetic: Fix typo in comment
+ * sched: energy saving: Avoid Tx dummy blocks on empty PDCH TS
+ * Fix crash with dyn TS when using direct pcu
+ * Use LOGPDCH macro to standarize log line
+ * cosmetic: sysmo: Drop unneded comment line
+ * bts: Use public getter instead of class member
+ * sched: Lower log level of RTS on disabled pdch
+ * pdch: Make sure pending ImmAssRej scheduled for disabled pdch are dropped
+ * Support Neighbor Address Resolution over PCUIF IPA multiplex
+ * nacc_fsm: Move logic checking if SI is being waited for to a func helper
+ * scheduler: Skip Tx DL idle blocks in TRX0 when not in DIRECT_PHY mode
+ * PTCCH: skip Tx DL idle blocks when possible
+ * tbf_ul_ass_fsm.c: Fix missing state transition in FSM description
+ * tbf: poll_timeout(): Validate expected poll reason
+ * nacc: Introduce helper function nacc_fsm_exp_ctrl_ack()
+ * tbf: refactor poll_timeout() with a switch statement
+ * tests: TbfTest: Fix wrong behavior in test_tbf_dl_reuse()
+ * pdch: refactor rcv_control_ack() with a switch statement
+ * cosmetic: Fix missing space
+ * assert if tbf pointer for POLL event is NULL
+ * tbf_fsm: Ignore event DL_ACKNACK_MISS in state RELEASING
+ * tests: RLCMACTest: Add one more sample RA capabilities to suite
+ * rlcmac: Fix CSN1 definition for DownlinkDualCarrierCapability_r7_t in MS RA cap
+ * tbf: Assert if FSM allocation fails
+ * sched: Rename function
+ * pdch: Only release ULC entry if rx ul block matches the expected one
+ * pdch: Validate poll reason matches in rcv_control_(egprs)_dl_ack_nack()
+ * pdch: PktResReq: Avoid releasing ULC entry if expecting something else on UL
+ * Handle Final UL ACK/NACK Confirmation in tbf_fsm
+ * tbf_fsm: rename state NULL -> NEW
+ * pdch_ulc: Log POLL reason upon timeout
+ * tbf_dl_ass_fsm: Move block msg generation conditions to rts() function
+ * tbf_ul_ass_fsm: Fix use of incorrect log macro
+ * tbf_fsm: Handle MAX_N3105 in state ASSIGN
+ * tbf: Use define to flag control_ts unset special value
+ * tbf: Document temporary change of control_ts and move code assigning it back to FSM
+ * Return void in tbf_assign_control_ts()
+ * pdch: rcv_data_block: Avoid releasing ULC entry if expecting something else on UL
+ * tbf: Avoid keeping poll nodes in pdch_ulc of temporary control_ts used during PACCH assignment
+ * tbf_ul_ass_fsm: Avoid retrying Pkt Ul Ass if tbf is not in state ASSIGN
+ * Abort scheduling of pending Pkt Ul Ass if tbf goes into RELEASE step
+ * tbf: Drop pending polls during free also on states != ASSIGN
+ * pdch: Simplify code path allocating UL TBF
+ * pdch: Log reason of expected POLL when receiving unexpected UL data
+ * bts_rcv_rach(): Gather pointers to data objects early and use them later
+ * bts_rcv_rach(): Split code paths for Ass and Ass Rej
+ * Get rid of tbf tsc field
+ * ts_alloc: Rename s/tbf_/tbf/
+ * tbf: Update FSM names when TFI change during tbf_update()
+ * tbf_fsm: Add assert verifying X2002 only triggers for DL TBF
+ * tbf: Assert if update() is called on UL TBF
+ * tbf: update(): return negative val on error
+ * tbf: Drop unneeded braces in one line condition
+ * cosmetic: Fix typo in comment
+ * pcuif: Submit data_req with len=0 as idle frames
+ * Split csn1.c into common, enc and dec files
+ * csn1: Add unit test showing RadioAccess Capability decoding failure
+ * csn1: Avoid failing if optional DownlinkDualCarrierCapability_r7 is missing
+ * csn1: Avoid storing existence bit as true if content was actually NULL
+ * csn1_dec.c: Fix stored bit in CSN_NEXT_EXIST_LH
+ * bts: Fix misleading log line in bts_rcv_rach()
+ * tbf_ul: Document context where tbf_alloc_ul_ccch() is used
+ * bts: Rename 11bit RACH request counter
+ * vty: Avoid crash in tbf_print_vty_info with null ptr ctrg
+ * vty: Log tbf_state when showing a TBF
+ * vty: show tbf: Drop unneeded check for non-null ms
+ * bts: Introduce new RACH req counters for one/two phase access
+ * bts: Improve logging to clarify RACH req is for 2 phase access
+ * bts: Count RACH Request with unexpected content
+ * tbf: Increase log level of line about unable to allocate poll for TBF
+ * pdch: Improve log line and increase log level
+ * tbf_ul: Set first_(common_)ts in handle_tbf_reject
+ * tbf: Set m_created_ts in constructor
+ * tbf: Mark initial first_(common_)ts with special value
+ * tbf: Set tfi to initial special value
+ * bts: Add counters for successful 1,2 phase pkt access
+ * tbf_ul: Update FSM names for dummy reject TBFs
+ * cosmetic: Add parenthesis around expression to clarify it
+ * pdch::rcv_resource_request(): Use local var to store bts pointer
+ * tbf_ul: Improve documentation of tbf_alloc_ul_pacch()
+ * Add counter for successful contention resolution procedures
+ * doc: Update counters_generated.adoc using osmo_vty_interact.py
+ * bts_pch_timer: Fix timer working only for MI type IMSI
+ * tests/alloc: Extend test_bts_pch_timer() to validate MI type TMSI
+ * bts_pch_timer: Avoid resend Paging Request over PCUIF if T3113 is armed
+ * pdch: Log line detaching TBF at start of the function
+ * pdch: Log TS enable/disable transitions
+ * pdch: Log DL TBF originating the new UL TBF
+ * ts_alloc: Simplify tfi_find_free logic
+ * ts_alloc: rename function to clraify what it does
+ * ts_alloc: rename variable to clarify meaning
+ * pdch: Update ms_reserved_slots in GprsMS when TS becomes disabled
+ * pdch: Drop previous UL TBF from MS who sent PktResReq through SBA
+ * pdch: Increase log level of line informing about TS control change
+ * tbf_ul_ass_fsm: Log both TBFs if old TBF is handling assignment for new one
+ * cosmetic: gprs_pcu.h: Fix typo in comment
+ * tbf_dl_ass_fsm: Log both TBFs if old TBF is handling assignment for new one
+ * tbf_dl_ass_fsm: Fix missing transition to NONE if DL TBF is nonexistent
+ * tbf_{dl,ul}_ass_fsm.c: use proper macro to log tbf
+ * pcu_main: Mark -r cmdline param as deprecated
+ * vty: Introduce command 'gsmtap-remote-host' and 'gsmtap-category enable-all'
+ * Fix MS ending up with assigned imsi 000
+ * bts: Add counter availablePDCHAllocatedTime
+ * tbf_dl_ass_fsm: Drop unsued X2000 timer callback
+ * T_defs_pcu: Set default val for X2000 to 0 ms
+ * Move T3172 T_defs_bts->T_defs_pcu to have it configurable in VTY
+
+ [ Alexander Couzens ]
+ * gprs_bssgp_pcu: rework BSSGP Reset messages to support SGSN originated BSSGP-RESET
+ * gprs_bssgp_pcu: ensure only known BVCI can be resetted by the SGSN
+ * gprs_bssgp_pcu: add comments to the pcu states
+
+ [ Harald Welte ]
+ * pdch_ul_controller: Fix compiler warning on gcc-10.2
+ * manual: remove revhistory, as we don't maintain it manually anyyway
+ * manual: Update copyright years
+ * vty: Add configuration for Gb DSCP and socket priority
+ * manual: Include QoS chapter and add osmo-pcu specific example
+
+ [ Vadim Yanitskiy ]
+ * gprs_rlcmac_sched: fix incorrect length for CTR_RLC_DL_BYTES
+ * PCUIF protocol: add message definition for interference report
+ * pcu_l1_if: ignore PDCH interference reports, do not log errors
+
+ [ Oliver Smith ]
+ * test: add 'make update_exp' target
+ * Add counters: pcu.sgsn.N.rx_paging_{cs,ps}
+ * Add counters: pcu.bts.N.pch.requests
+ * Add counters: pcu.bts.N.pch.requests.timeout
+ * bts: delete pch_timer list in destructor
+ * tests: make update_exp: build check_PROGRAMS first
+ * debian/control: remove dh-systemd build-depend
+ * Add stats: pcu.bts.N.pdch.available/occupied
+ * Add stats: pcu.bts.N.pdch.occupied.gprs/egprs
+ * pdch: has_gprs_only_tb_attached: use m_num_tbfs
+
+ [ Neels Hofmeyr ]
+ * T_defs_bts: remove unit from doc strings
+ * Revert "Stop abusing T3169"
+ * fix: handle NULL return of as_dl_tbf() and as_ul_tbf()
+ * coverity: fix null deref from recent UL TBF leak fix
+
+ [ Daniel Willmann ]
+ * gprs_bssgp_pcu: Fix crash when configuring an existing ns bind
+
+ -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 16 Nov 2021 16:47:29 +0100
+
osmo-pcu (0.9.0) unstable; urgency=medium
[ Pau Espin Pedrol ]