aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2c080ed9..e23a40fd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,16 @@
AUTOMAKE_OPTIONS = foreign dist-bzip2 1.6
SUBDIRS = src examples
+EXTRA_DIST = osmoappdesc.py
+
+if ENABLE_VTY_TESTS
+python-tests: $(BUILT_SOURCES)
+ osmotestvty.py -p $(top_srcdir) -w $(builddir) -v
+ osmotestconfig.py -p $(top_srcdir) -w $(builddir) -v
+else
+python-tests: $(BUILT_SOURCES)
+ @echo "Not running python-based tests (determined at configure-time)"
+endif
+
+check-local: $(BUILT_SOURCES)
+ $(MAKE) $(AM_MAKEFLAGS) python-tests