aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2013-10-17 20:12:37 +0200
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2013-10-30 21:20:45 +0100
commitb78adcdd11ef0414c2594bada2a37d498d32f1ef (patch)
treecd0bff850d78d4b4f9c53fee407ac202c6feb854 /src/Makefile.am
parent9b30c7f46e2c55aed06cea8d1daa9093f331fb20 (diff)
bts: Introduce a PollController that has the responsibility to poll
For each frame indication received by the BTS the poll controller is asked to expire timedout entries.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 012f8a9f..272827d0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -43,7 +43,8 @@ libgprs_la_SOURCES = \
pcu_l1_if.cpp \
pcu_vty.c \
tbf.cpp \
- bts.cpp
+ bts.cpp \
+ poll_controller.cpp
if ENABLE_SYSMOBTS
libgprs_la_SOURCES += \
@@ -77,7 +78,8 @@ noinst_HEADERS = \
sysmo_l1_if.h \
femtobts.h \
tbf.h \
- bts.h
+ bts.h \
+ poll_controller.h
osmo_pcu_SOURCES = pcu_main.cpp