aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJacob Erlbeck <jerlbeck@sysmocom.de>2015-05-11 14:13:47 +0200
committerJacob Erlbeck <jerlbeck@sysmocom.de>2015-05-20 11:36:06 +0200
commitdfef28de887eba43747bca52584f8310450e243a (patch)
tree832955e5ad880c2913bc55b7c8217fc34bc9570c /src/Makefile.am
parent67c385046dbf4fe00871bb9f56b6b82e1f9d1348 (diff)
llist: Add a C++ wrapper for linux_list
This commit adds the LListHead class which is a wrapper around the linuxlist. It adds an additional member to refer to the container, since the container_of macro doesn't work properly with C++ classes. All functions and macros from linuxlist.h are support except for the entry macros (e.g. llist_entry, llist_for_each_entry, ...). To access the container (entry), an entry() method is provided instead: llist_for_each(pos, &elems) { pos->entry()->do_something(); } Sponsored-by: On-Waves ehf
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 8a422f64..0398028c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -95,7 +95,8 @@ noinst_HEADERS = \
rlc.h \
decoding.h \
llc.h \
- pcu_utils.h
+ pcu_utils.h \
+ cxx_linuxlist.h
osmo_pcu_SOURCES = pcu_main.cpp