aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJacob Erlbeck <jerlbeck@sysmocom.de>2015-06-04 09:42:14 +0200
committerJacob Erlbeck <jerlbeck@sysmocom.de>2015-06-08 09:39:43 +0200
commit62e96a3535714088a5dabe3cb4a8523165b19877 (patch)
tree14be557e47f903a506624a50ba11d58b41687181 /src/Makefile.am
parenta700dd9e11d31805cfe8dd07fc27ac96425cbf0c (diff)
vty: Add a file for C++ functions
Currently the pcu_vty.c doesn't compile with C++. Thus C++ object cannot be access directly there. This commit adds a helper C++ file that exports all functions with C calling conventions and naming to work around that limitation until the transition of pcu_vty.c is completed. Sponsored-by: On-Waves ehf
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 35ba7a92..b18c1cea 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -43,6 +43,7 @@ libgprs_la_SOURCES = \
bitvector.cpp \
pcu_l1_if.cpp \
pcu_vty.c \
+ pcu_vty_functions.cpp \
tbf.cpp \
tbf_ul.cpp \
tbf_dl.cpp \
@@ -85,6 +86,7 @@ noinst_HEADERS = \
gsm_timer.h \
bitvector.h \
pcu_vty.h \
+ pcu_vty_functions.h \
sysmo_l1_if.h \
femtobts.h \
tbf.h \