aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2013-08-24 18:31:27 +0200
committerIvan Kluchnikov <kluchnikovi@gmail.com>2013-10-18 15:15:49 +0400
commit17c31ce173699377da5d44b3bdb69583c400d5b9 (patch)
tree7e9a6009949adef726bd80efc11051de90ca86d9 /src/Makefile.am
parentdcc9c39529556ca20cb8bd98758ea8caa023f259 (diff)
tbf: Begin to add some structure to the tbf code
The TBF should use the IMSI to identify a block flow but all handling is spread across the entire code. Start to clean this up by moving relevant code into the tbf file. Afterwards one can clean up and add more internal structure.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 38a4b3c8..6646f534 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -40,7 +40,8 @@ libgprs_la_SOURCES = \
gsm_timer.cpp \
bitvector.cpp \
pcu_l1_if.cpp \
- pcu_vty.c
+ pcu_vty.c \
+ tbf.cpp
if ENABLE_SYSMOBTS
libgprs_la_SOURCES += \
@@ -72,7 +73,8 @@ noinst_HEADERS = \
bitvector.h \
pcu_vty.h \
sysmo_l1_if.h \
- femtobts.h
+ femtobts.h \
+ tbf.h
osmo_pcu_SOURCES = pcu_main.cpp