aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2017-06-11 11:36:33 +0200
committerHarald Welte <laforge@gnumonks.org>2017-06-11 11:40:18 +0200
commitc136be04f7784d245baf0adb2e2537ac0fae206d (patch)
tree4b22d3f1dce5d1e1250756b63eb9b52b66eb5b5d /src/Makefile.am
parent0fb294a8dd45a86b8f9eb93211b69b6dbf0a6853 (diff)
lc15: further fixes regarding --with-litecell15
The fix in 0fb294a8dd45a86b8f9eb93211b69b6dbf0a6853 was only partially valid, as it unconditionally used $includedir, without any prefix. This polluted the include path with host include files in cross-compiling builds. Let's take a different approach and simply define LITECELL15_CFLAGS (similar to what pkgconfig does), which makes the "-I" go away if no --with-litecell15 has been specified. Change-Id: I63393decfe42a24dab56c7654f716c1580416ab2
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 97de06d1..1543851d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -137,7 +137,7 @@ osmo_pcu_remote_LDADD = \
endif
if ENABLE_LC15BTS_PHY
-AM_CPPFLAGS += -I$(LITECELL15_INCDIR) -I$(srcdir)/osmo-bts-litecell15
+AM_CPPFLAGS += $(LITECELL15_CFLAGS) -I$(srcdir)/osmo-bts-litecell15
EXTRA_DIST = \
osmo-bts-litecell15/lc15_l1_if.c \