aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNeels Hofmeyr <nhofmeyr@sysmocom.de>2016-10-01 00:52:10 +0200
committerNeels Hofmeyr <nhofmeyr@sysmocom.de>2016-10-01 01:06:19 +0200
commitda66f71ffeee47575d0fc0c3c2c6fb304d50e3cc (patch)
tree59bc86d8846600cbf8ee2e511764f204d540e6f5 /configure.ac
parentda933e0ff8a63943a1f738c7172a9c7ede972849 (diff)
configure: check for pkg-config presence
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e1a23c02..950be230 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,6 +19,13 @@ AC_PROG_CXX
AC_PROG_INSTALL
LT_INIT
+dnl check for pkg-config (explained in detail in libosmocore/configure.ac)
+AC_PATH_PROG(PKG_CONFIG_INSTALLED, pkg-config, no)
+if test "x$PKG_CONFIG_INSTALLED" = "xno"; then
+ AC_MSG_WARN([You need to install pkg-config])
+fi
+PKG_PROG_PKG_CONFIG([0.20])
+
dnl checks for header files
AC_HEADER_STDC