aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPhilipp Maier <pmaier@sysmocom.de>2023-02-03 16:52:42 +0100
committerPhilipp Maier <pmaier@sysmocom.de>2023-03-20 10:54:28 +0100
commit4bac39892399e2056fc03981140d654eb65b6e54 (patch)
tree3e629a22a4562a15e4cd1c761873f4b86d3a286e /configure.ac
parentb5a8a67dfee9c036cb4766801c00d93ba9e7b8b8 (diff)
support for Ericsson RBS E1 CCU
Ericsson RBS series BTSs do not have a built in PCU. Rather than having the PCU on board the PCU is co-located to the BSC in those cases. Just like the MGW the PCU would connect to the CCU (Channel Coding Unit) via E1 line. The PCU is connected via an unix domain socket (pcu_sock) to the BSC to receive RACH requests and to control Paging and TBF assignment. This patch adds all the required functionality to run an Ercisson RBS in GPRS/EGPRS mode. It supports 16k I.460 E1 subslots and full 64k E1 timeslots (recommended) Change-Id: I5c0a76667339ca984a12cbd2052f5d9e5b0f9c4d Related: OS#5198
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 31286f41..bad70e30 100644
--- a/configure.ac
+++ b/configure.ac
@@ -167,6 +167,18 @@ if test "$enable_oc2g" = "yes"; then
CPPFLAGS=$oldCPPFLAGS
fi
+AC_MSG_CHECKING([whether to enable direct E1 CCU access for PDCH of Ericsson RBS])
+AC_ARG_ENABLE(er-e1-ccu,
+ AC_HELP_STRING([--enable-er-e1-ccu],
+ [enable code for Ericsson RBS E1 CCU [default=no]]),
+ [enable_er_e1_ccu="$enableval"],[enable_er_e1_ccu="no"])
+AC_MSG_RESULT([$enable_er_e1_ccu])
+AM_CONDITIONAL(ENABLE_ER_E1_CCU, test "x$enable_er_e1_ccu" = "xyes")
+AS_IF([test "x$enable_er_e1_ccu" = "xyes"], [
+ PKG_CHECK_MODULES(LIBOSMOABIS, libosmoabis >= 1.4.0)
+ PKG_CHECK_MODULES(LIBOSMOTRAU, libosmotrau >= 1.4.0)
+])
+
AC_ARG_ENABLE([vty_tests],
AC_HELP_STRING([--enable-vty-tests],
[Include the VTY tests in make check [default=no]]),