aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2013-07-28 16:15:41 +0200
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2013-07-30 21:24:26 +0200
commitc0a6938d0ede31b7c94e74ad598efb952aa2a613 (patch)
tree4b4ed9082091555ff2c7fe0c55d79041d25b8b74 /Makefile.am
parent904bc8023fcecdfd8ba5abe2b46d8e2fb56e8d3b (diff)
tests: Create tests directory and move the VTY testing into there
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 1 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index e23a40fd..4cbc1147 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,16 +1,5 @@
AUTOMAKE_OPTIONS = foreign dist-bzip2 1.6
-SUBDIRS = src examples
+SUBDIRS = src examples tests
EXTRA_DIST = osmoappdesc.py
-if ENABLE_VTY_TESTS
-python-tests: $(BUILT_SOURCES)
- osmotestvty.py -p $(top_srcdir) -w $(builddir) -v
- osmotestconfig.py -p $(top_srcdir) -w $(builddir) -v
-else
-python-tests: $(BUILT_SOURCES)
- @echo "Not running python-based tests (determined at configure-time)"
-endif
-
-check-local: $(BUILT_SOURCES)
- $(MAKE) $(AM_MAKEFLAGS) python-tests