aboutsummaryrefslogtreecommitdiffstats
path: root/tests/xid/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/xid/Makefile.am')
-rw-r--r--tests/xid/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/tests/xid/Makefile.am b/tests/xid/Makefile.am
new file mode 100644
index 000000000..aaf17edf2
--- /dev/null
+++ b/tests/xid/Makefile.am
@@ -0,0 +1,39 @@
+AM_CPPFLAGS = \
+ $(all_includes) \
+ -I$(top_srcdir)/include \
+ $(NULL)
+
+AM_CFLAGS = \
+ -Wall \
+ -ggdb3 \
+ $(LIBOSMOCORE_CFLAGS) \
+ $(LIBOSMOGSM_CFLAGS) \
+ $(LIBCARES_CFLAGS) \
+ $(NULL)
+
+EXTRA_DIST = \
+ xid_test.ok \
+ $(NULL)
+
+noinst_PROGRAMS = \
+ xid_test \
+ $(NULL)
+
+xid_test_SOURCES = \
+ xid_test.c \
+ $(NULL)
+
+xid_test_LDADD = \
+ $(top_builddir)/src/gprs/gprs_llc_xid.o \
+ $(top_builddir)/src/libcommon/libcommon.a \
+ $(LIBOSMOABIS_LIBS) \
+ $(LIBOSMOCORE_LIBS) \
+ $(LIBOSMOGSM_LIBS) \
+ $(LIBOSMOGB_LIBS) \
+ $(LIBCARES_LIBS) \
+ $(LIBCRYPTO_LIBS) \
+ $(LIBGTP_LIBS) \
+ -lrt \
+ -lm \
+ $(NULL)
+