aboutsummaryrefslogtreecommitdiffstats
path: root/libosmocore/include/osmocore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libosmocore/include/osmocore/Makefile.am')
-rw-r--r--libosmocore/include/osmocore/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/libosmocore/include/osmocore/Makefile.am b/libosmocore/include/osmocore/Makefile.am
new file mode 100644
index 000000000..fb4f089b7
--- /dev/null
+++ b/libosmocore/include/osmocore/Makefile.am
@@ -0,0 +1,12 @@
+osmocore_HEADERS = signal.h linuxlist.h timer.h select.h msgb.h \
+ tlv.h bitvec.h comp128.h statistics.h gsm_utils.h utils.h \
+ gsmtap.h write_queue.h rsl.h gsm48.h rxlev_stat.h mncc.h \
+ gsm48_ie.h
+
+if ENABLE_TALLOC
+osmocore_HEADERS += talloc.h
+endif
+
+osmocoredir = $(includedir)/osmocore
+
+SUBDIRS = protocol