aboutsummaryrefslogtreecommitdiffstats
path: root/doc/sequence_charts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/sequence_charts/Makefile.am')
-rw-r--r--doc/sequence_charts/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/doc/sequence_charts/Makefile.am b/doc/sequence_charts/Makefile.am
new file mode 100644
index 000000000..b667a6f5e
--- /dev/null
+++ b/doc/sequence_charts/Makefile.am
@@ -0,0 +1,35 @@
+all:
+ echo "built only on manual invocation, needs mscgen and dot (graphviz) programs: invoke 'make charts'"
+
+charts: msc dot
+
+EXTRA_DIST = \
+ inter_bsc_ho.msc \
+ inter_msc_ho.msc \
+ mncc_fsm.msc \
+ $(NULL)
+
+CLEANFILES = \
+ inter_bsc_ho.png \
+ inter_msc_ho.png \
+ mncc_fsm.png \
+ $(NULL)
+
+msc: \
+ $(builddir)/mncc_fsm.png \
+ $(builddir)/inter_bsc_ho.png \
+ $(builddir)/inter_msc_ho.png \
+ $(NULL)
+
+dot: \
+ $(NULL)
+
+$(builddir)/%.png: $(srcdir)/%.msc
+ mscgen -T png -o $@ $<
+
+$(builddir)/%.png: $(srcdir)/%.dot
+ dot -Tpng $< > $@
+
+.PHONY: poll
+poll:
+ while true; do $(MAKE) msc dot; sleep 1; done