aboutsummaryrefslogtreecommitdiffstats
path: root/tests/msc_vlr/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <neels@hofmeyr.de>2018-03-02 01:50:09 +0100
committerNeels Hofmeyr <neels@hofmeyr.de>2018-03-02 17:00:37 +0100
commitda21a52c927b09949bfc1a5d18648d19c8fd3df1 (patch)
treebd3b16ff2ca68c85cd1726801702d85bd274ad25 /tests/msc_vlr/Makefile.am
parentf3d81f6ef5aea1a60700b45d79f14edb4adc8295 (diff)
msc_vlr_tests: improve cipher mode coverage
Actually call msc_vlr_set_ciph_mode() and wrap away a_iface_tx_cipher_mode() and ranap_iu_tx_sec_mode_cmd(). Hence we'll see decisions and errors in msc_vlr_set_ciph_mode() as well. Change-Id: Id23bc245d4b5707edcd27c44db272fbb211bf9bd
Diffstat (limited to 'tests/msc_vlr/Makefile.am')
-rw-r--r--tests/msc_vlr/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/msc_vlr/Makefile.am b/tests/msc_vlr/Makefile.am
index 43b4e0749..8194f222b 100644
--- a/tests/msc_vlr/Makefile.am
+++ b/tests/msc_vlr/Makefile.am
@@ -32,6 +32,8 @@ AM_LDFLAGS = \
-Wl,--wrap=osmo_get_rand_id \
-Wl,--wrap=msc_mgcp_call_release \
-Wl,--wrap=msc_mgcp_call_assignment \
+ -Wl,--wrap=a_iface_tx_cipher_mode \
+ -Wl,--wrap=ranap_iu_tx_sec_mode_cmd \
$(NULL)
LDADD = \