aboutsummaryrefslogtreecommitdiffstats
path: root/tests/msc_vlr/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <neels@hofmeyr.de>2017-07-05 15:19:52 +0200
committerHarald Welte <laforge@gnumonks.org>2017-08-29 12:51:18 +0000
commit00e82d61ab7bbdcf09c2c88c159dd6e8fac72387 (patch)
tree83aa888237576c3ca6ca22b82b6b9eb9f3b63b12 /tests/msc_vlr/Makefile.am
parent6d82bec2c8cd3636fbce09757610762e5bd85b06 (diff)
move libiu to osmo-iuh/libosmo-ranap
Remove libiu here, use the functions from libosmo-ranap instead, by applying the ranap_ / RANAP_ prefix. Corresponding change-id in osmo-iuh.git is I6a3f7ad15be03fb94689b4af6ccfa828c25f45c0 To be able to run the msc_vlr tests for RAN_UTRAN_IU without Iu client headers available, add iu_dummy.h, containing mere function signatures that match iu_dummy.c and a mostly empty struct ranap_ue_conn_ctx. Make sure we can build with and without --enable-iu: include osmo-iuh headers only with --enable-iu. Change-Id: Ib8c4fcdb4766c5e575618b95ce16dce51063206b
Diffstat (limited to 'tests/msc_vlr/Makefile.am')
-rw-r--r--tests/msc_vlr/Makefile.am15
1 files changed, 4 insertions, 11 deletions
diff --git a/tests/msc_vlr/Makefile.am b/tests/msc_vlr/Makefile.am
index 6d51d6eba..3ae0c84fc 100644
--- a/tests/msc_vlr/Makefile.am
+++ b/tests/msc_vlr/Makefile.am
@@ -50,13 +50,6 @@ COMMON_LDADD = \
$(top_builddir)/src/libtrau/libtrau.a \
$(top_builddir)/src/libmgcp/libmgcp.a \
$(top_builddir)/src/libcommon/libcommon.a \
- $(NULL)
-if BUILD_IU
-COMMON_LDADD += \
- $(top_builddir)/src/libiu/libiu.a \
- $(NULL)
-endif
-COMMON_LDADD += \
$(LIBSMPP34_LIBS) \
$(LIBOSMOCORE_LIBS) \
$(LIBOSMOGSM_LIBS) \
@@ -76,10 +69,10 @@ COMMON_LDFLAGS = \
-Wl,--wrap=a_iface_tx_dtap \
-Wl,--wrap=a_iface_tx_clear_cmd \
-Wl,--wrap=a_iface_tx_paging \
- -Wl,--wrap=iu_tx \
- -Wl,--wrap=iu_tx_release \
- -Wl,--wrap=iu_tx_common_id \
- -Wl,--wrap=iu_page_cs \
+ -Wl,--wrap=ranap_iu_tx \
+ -Wl,--wrap=ranap_iu_tx_release \
+ -Wl,--wrap=ranap_iu_tx_common_id \
+ -Wl,--wrap=ranap_iu_page_cs \
-Wl,--wrap=msc_stop_paging \
-Wl,--wrap=gsm340_gen_scts \
-Wl,--wrap=RAND_bytes \