aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <neels@hofmeyr.de>2017-07-06 18:39:28 +0200
committerHarald Welte <laforge@gnumonks.org>2017-08-29 12:51:19 +0000
commitbac227653a372d8cbd611eefe59ca40ab96dedab (patch)
tree8713a770780b3ba9a4d791b993c7ecc9d2454d97 /tests/Makefile.am
parent4585317f1b55789e0a1edeb18b1a977e00ce30d5 (diff)
split off osmo-msc: remove files, apply build, rename
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am37
1 files changed, 1 insertions, 36 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 7e17ad8de..c225afab9 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,48 +1,13 @@
SUBDIRS = \
- gsm0408 \
- channel \
- gprs \
- abis \
- gbproxy \
- trau \
- subscr \
- nanobts_omlattr \
sms_queue \
msc_vlr \
$(NULL)
-if BUILD_NAT
-SUBDIRS += \
- bsc-nat \
- bsc-nat-trie \
- $(NULL)
-endif
-if BUILD_BSC
-SUBDIRS += \
- bsc \
- $(NULL)
-endif
if BUILD_SMPP
SUBDIRS += \
smpp \
$(NULL)
endif
-if HAVE_LIBGTP
-SUBDIRS += \
- gtphub \
- $(NULL)
-
-if HAVE_LIBCARES
-SUBDIRS += \
- sgsn \
- oap \
- xid \
- sndcp_xid \
- slhc \
- v42bis \
- $(NULL)
-endif
-endif
# The `:;' works around a Bash 3.2 bug when the output is not writeable.
$(srcdir)/package.m4: $(top_srcdir)/configure.ac
@@ -86,7 +51,7 @@ python-tests: $(BUILT_SOURCES)
if BUILD_SMPP
$(PYTHON) $(srcdir)/smpp_test_runner.py -w $(abs_top_builddir) -v
endif
- rm -f $(top_builddir)/sms.db $(top_builddir)/gsn_restart $(top_builddir)/gtphub_restart_count
+ rm -f $(top_builddir)/sms.db
else
python-tests: $(BUILT_SOURCES)
echo "Not running python-based tests (determined at configure-time)"