aboutsummaryrefslogtreecommitdiffstats
path: root/src/utils/Makefile.am
diff options
context:
space:
mode:
authorMax <msuraev@sysmocom.de>2022-07-28 14:19:22 +0700
committerMax <msuraev@sysmocom.de>2022-08-05 22:12:09 +0700
commit5346f69a543eab087380be117d625bbaf82ebd4b (patch)
treec1d785f8b6bd5616f576d124dcce0a530d293ef6 /src/utils/Makefile.am
parent3948fcc4760f096f41ac00679e38d47bcb7ba2d5 (diff)
Introduce libsmpputil
As part of preparation for libosmo-netif migration let's move common SMPP code into separate build-time library and use it for both smpp_mirror and OsmoMSC renaming the files if necessary. While at it we also fix id/password legth limits in smpp_mirror and drop unused fields from ESME struct. Related: OS#5568 Change-Id: I61910651bc7c188dc2fb67d96189a66a47e7e8fb
Diffstat (limited to 'src/utils/Makefile.am')
-rw-r--r--src/utils/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/utils/Makefile.am b/src/utils/Makefile.am
index cb0faf69f..75a292609 100644
--- a/src/utils/Makefile.am
+++ b/src/utils/Makefile.am
@@ -34,12 +34,16 @@ smpp_mirror_SOURCES = \
smpp_mirror_CFLAGS = \
$(LIBOSMOCORE_CFLAGS) \
+ $(LIBOSMOSCCP_CFLAGS) \
+ $(LIBOSMOMGCPCLIENT_CFLAGS) \
$(LIBSMPP34_CFLAGS) \
$(NULL)
smpp_mirror_LDADD = \
+ $(top_builddir)/src/libsmpputil/libsmpputil.a \
$(LIBOSMOCORE_LIBS) \
$(LIBOSMOGSM_LIBS) \
+ $(LIBOSMONETIF_LIBS) \
$(LIBSMPP34_LIBS) \
$(NULL)
endif