aboutsummaryrefslogtreecommitdiffstats
path: root/src/libmsc/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <neels@hofmeyr.de>2017-07-05 15:19:52 +0200
committerHarald Welte <laforge@gnumonks.org>2017-08-29 12:51:18 +0000
commit00e82d61ab7bbdcf09c2c88c159dd6e8fac72387 (patch)
tree83aa888237576c3ca6ca22b82b6b9eb9f3b63b12 /src/libmsc/Makefile.am
parent6d82bec2c8cd3636fbce09757610762e5bd85b06 (diff)
move libiu to osmo-iuh/libosmo-ranap
Remove libiu here, use the functions from libosmo-ranap instead, by applying the ranap_ / RANAP_ prefix. Corresponding change-id in osmo-iuh.git is I6a3f7ad15be03fb94689b4af6ccfa828c25f45c0 To be able to run the msc_vlr tests for RAN_UTRAN_IU without Iu client headers available, add iu_dummy.h, containing mere function signatures that match iu_dummy.c and a mostly empty struct ranap_ue_conn_ctx. Make sure we can build with and without --enable-iu: include osmo-iuh headers only with --enable-iu. Change-Id: Ib8c4fcdb4766c5e575618b95ce16dce51063206b
Diffstat (limited to 'src/libmsc/Makefile.am')
-rw-r--r--src/libmsc/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/src/libmsc/Makefile.am b/src/libmsc/Makefile.am
index 9f246b3d8..c9b8bb4cc 100644
--- a/src/libmsc/Makefile.am
+++ b/src/libmsc/Makefile.am
@@ -35,8 +35,6 @@ libmsc_a_SOURCES = \
gsm_04_14.c \
gsm_04_80.c \
gsm_subscriber.c \
- iucs.c \
- iucs_ranap.c \
mncc.c \
mncc_builtin.c \
mncc_sock.c \
@@ -52,7 +50,12 @@ libmsc_a_SOURCES = \
meas_feed.c \
subscr_conn.c \
$(NULL)
-if !BUILD_IU
+if BUILD_IU
+libmsc_a_SOURCES += \
+ iucs.c \
+ iucs_ranap.c \
+ $(NULL)
+else
libmsc_a_SOURCES += \
iu_dummy.c \
$(NULL)