aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/vlr/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2016-06-17 00:06:42 +0200
committerNeels Hofmeyr <nhofmeyr@sysmocom.de>2017-03-16 15:32:29 +0100
commit067991aeb2b404f120678bd618ebd15614de3446 (patch)
tree40045d6ece907a712acf6c37659427b1d6638620 /openbsc/tests/vlr/Makefile.am
parente005619dc6cbfcbd260cab6b2535d10eb0e75c6d (diff)
Add libvlr implementation
Original libvlr code is by Harald Welte <laforge@gnumonks.org>, polished and tweaked by Neels Hofmeyr <nhofmeyr@sysmocom.de>. This is a long series of development collapsed in one patch. The original history may still be available as branch neels/vlr_orig. Related: OS#1592 Change-Id: I3f75de5f0cc2ff77f276fd39832dd3621309c4b9
Diffstat (limited to 'openbsc/tests/vlr/Makefile.am')
-rw-r--r--openbsc/tests/vlr/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/openbsc/tests/vlr/Makefile.am b/openbsc/tests/vlr/Makefile.am
new file mode 100644
index 000000000..2208a6f59
--- /dev/null
+++ b/openbsc/tests/vlr/Makefile.am
@@ -0,0 +1,22 @@
+AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include
+AM_CFLAGS = -Wall -ggdb3 \
+ $(LIBOSMOCORE_CFLAGS) \
+ $(LIBOSMOGSM_CFLAGS) \
+ $(COVERAGE_CFLAGS) \
+ $(LIBOSMOABIS_CFLAGS) \
+ $(NULL)
+AM_LDFLAGS = $(COVERAGE_LDFLAGS)
+
+noinst_PROGRAMS = vlr_test
+
+vlr_test_SOURCES = vlr_test.c
+vlr_test_LDADD = \
+ $(top_builddir)/src/libvlr/libvlr.a \
+ $(top_builddir)/src/libcommon/libcommon.a \
+ $(LIBOSMOCORE_LIBS) \
+ $(LIBOSMOGSM_LIBS) \
+ $(LIBOSMOVTY_LIBS) \
+ $(LIBOSMOABIS_LIBS) \
+ $(LIBRARY_DL) \
+ $(LIBCRYPTO_LIBS) \
+ $(NULL)