aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/gprs/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2011-06-23 17:53:27 -0400
committerHolger Hans Peter Freyther <zecke@selfish.org>2012-01-06 18:52:05 +0100
commitfaf1f64a2d0a54d37616a8bec8691346ab792cde (patch)
treecf9f5052348eae7207bceeb9803967686ca3e692 /openbsc/tests/gprs/Makefile.am
parent26d0fe3c89042ed4008903dbe12c5110d8f9fc48 (diff)
gprs: Honor GSM 04.64 8.4.2 Receipt of unacknowledged information
GSM 04.64 8.4.2 asks to ignore UI frames if the DLCI is not known, or if the "(V(UR)- 32) <= N(U) < V(UR)". E.g. if we want to have V(UR) == 511 and this frame is dropped, we would ignore N(U)'s 0 to 510. Calculate the delta. The code is based on Jonathan Santos's "LLC UI window" fix but the issue was discovered independly.
Diffstat (limited to 'openbsc/tests/gprs/Makefile.am')
-rw-r--r--openbsc/tests/gprs/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/openbsc/tests/gprs/Makefile.am b/openbsc/tests/gprs/Makefile.am
new file mode 100644
index 000000000..e44125967
--- /dev/null
+++ b/openbsc/tests/gprs/Makefile.am
@@ -0,0 +1,8 @@
+INCLUDES = $(all_includes) -I$(top_srcdir)/include
+AM_CFLAGS=-Wall -ggdb3 $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS)
+
+EXTRA_DIST = gprs_test.ok
+
+noinst_PROGRAMS = gprs_test
+
+gprs_test_SOURCES = gprs_test.c