aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/gprs/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2014-08-04 14:22:13 +0200
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2014-08-04 15:00:54 +0200
commitce1b22e817584d512f82a711c02b67d12346c202 (patch)
tree5318c4557958272364f66e954359b6bbb7a36edb /openbsc/tests/gprs/Makefile.am
parent4d9fc422d2dd17118d70a2ed25ab383614a81ede (diff)
gprs: Add testcases for the APN string/octet conversion and fix it
Create a testcase for the gprs_str_to_apn and gprs_apn_to_str routines. While writing the testcase we noticed it is possible to write more bytes than should have been allowed. This is fixed by checking that the max_len is at least 1 (needed to write the first length octet) and to do the size check before writing to the output. Modify the signature of gprs_str_to_apn to put the length/size next to the parameter that requires a size. Done with Jacob
Diffstat (limited to 'openbsc/tests/gprs/Makefile.am')
-rw-r--r--openbsc/tests/gprs/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/openbsc/tests/gprs/Makefile.am b/openbsc/tests/gprs/Makefile.am
index 904d567c1..193655fa4 100644
--- a/openbsc/tests/gprs/Makefile.am
+++ b/openbsc/tests/gprs/Makefile.am
@@ -5,4 +5,5 @@ EXTRA_DIST = gprs_test.ok
noinst_PROGRAMS = gprs_test
-gprs_test_SOURCES = gprs_test.c
+gprs_test_SOURCES = gprs_test.c $(top_srcdir)/src/gprs/gprs_utils.c
+gprs_test_LDADD = $(LIBOSMOCORE_LIBS)