aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/bsc-nat/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2010-03-30 05:57:42 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-03-30 05:57:42 +0200
commitd44d4c8c8b9b751f60b10dcac37e05a31ccddc88 (patch)
tree1aa4d2a7a7acf3208a79112073ed5ad584222dc4 /openbsc/tests/bsc-nat/Makefile.am
parentaf0e1d7a859a94857cf8042a8e392d6e13b27c24 (diff)
nat: Move paging by lac handling code into the utils file
Moving it here means we can more easily test this code, there is one behaviour change with the code that we only support paging messages with one LAC and will silently ignore the others.
Diffstat (limited to 'openbsc/tests/bsc-nat/Makefile.am')
-rw-r--r--openbsc/tests/bsc-nat/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/openbsc/tests/bsc-nat/Makefile.am b/openbsc/tests/bsc-nat/Makefile.am
index bb2bd06fd..7011fbd45 100644
--- a/openbsc/tests/bsc-nat/Makefile.am
+++ b/openbsc/tests/bsc-nat/Makefile.am
@@ -8,6 +8,7 @@ noinst_PROGRAMS = bsc_nat_test
bsc_nat_test_SOURCES = bsc_nat_test.c \
$(top_srcdir)/src/nat/bsc_filter.c \
$(top_srcdir)/src/nat/bsc_sccp.c \
- $(top_srcdir)/src/nat/bsc_nat_utils.c
+ $(top_srcdir)/src/nat/bsc_nat_utils.c \
+ $(top_srcdir)/src/bssap.c
bsc_nat_test_LDADD = $(top_builddir)/src/libbsc.a $(top_builddir)/src/libsccp.a $(LIBOSMOCORE_LIBS)