aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/bsc-nat/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2010-03-29 17:43:06 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-03-30 02:43:11 +0200
commitaf0e1d7a859a94857cf8042a8e392d6e13b27c24 (patch)
treeb086fd415eaa2ab8b49b6406e901641255bc1c4a /openbsc/tests/bsc-nat/Makefile.am
parentd21b4d7f9867bfc00c86e5cf26bc5a056a03ef24 (diff)
nat: Add a test case for the connection tracking
This test case tests connectiont tracking by sending a CR, getting a CC, sending a DTAP, receiving a DTAP, receiving a RLSD, sending a RLC. It verifies that the messages are properly patched specially the references at the BSC.
Diffstat (limited to 'openbsc/tests/bsc-nat/Makefile.am')
-rw-r--r--openbsc/tests/bsc-nat/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/openbsc/tests/bsc-nat/Makefile.am b/openbsc/tests/bsc-nat/Makefile.am
index 550f0a820..bb2bd06fd 100644
--- a/openbsc/tests/bsc-nat/Makefile.am
+++ b/openbsc/tests/bsc-nat/Makefile.am
@@ -1,8 +1,13 @@
INCLUDES = $(all_includes) -I$(top_srcdir)/include
AM_CFLAGS=-Wall -ggdb3 $(LIBOSMOCORE_CFLAGS)
+EXTRA_DIST = bsc_data.c
+
noinst_PROGRAMS = bsc_nat_test
-bsc_nat_test_SOURCES = bsc_nat_test.c $(top_srcdir)/src/nat/bsc_filter.c
+bsc_nat_test_SOURCES = bsc_nat_test.c \
+ $(top_srcdir)/src/nat/bsc_filter.c \
+ $(top_srcdir)/src/nat/bsc_sccp.c \
+ $(top_srcdir)/src/nat/bsc_nat_utils.c
bsc_nat_test_LDADD = $(top_builddir)/src/libbsc.a $(top_builddir)/src/libsccp.a $(LIBOSMOCORE_LIBS)