aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2012-01-09 22:53:04 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2012-01-09 22:53:04 +0100
commit93ef33edb6f7436759e6276b5b208faf49a87f31 (patch)
treea7f1aa8f2349a2fe57e27c6960e222abae8e1f7e /openbsc/tests/Makefile.am
parent03ff1c847762174737eaa30e763d2d1eb51a4d2f (diff)
tests: Use atlocal/atlocal.in to enable/disable the NAT test
Kill the hacking, use atlocal to remember if the NAT test should be enabled and then skip the test (exit with 77).
Diffstat (limited to 'openbsc/tests/Makefile.am')
-rw-r--r--openbsc/tests/Makefile.am6
1 files changed, 1 insertions, 5 deletions
diff --git a/openbsc/tests/Makefile.am b/openbsc/tests/Makefile.am
index 73e8b89e6..9722b1458 100644
--- a/openbsc/tests/Makefile.am
+++ b/openbsc/tests/Makefile.am
@@ -2,14 +2,11 @@ SUBDIRS = debug gsm0408 db channel mgcp gprs
if BUILD_NAT
SUBDIRS += bsc-nat
-ENABLE_NAT_TEST = echo 'm4_define([ENABLE_NAT_TEST], [1])';
-else
-ENABLE_NAT_TEST = echo '';
endif
# The `:;' works around a Bash 3.2 bug when the output is not writeable.
-$(srcdir)/package.m4: $(top_srcdir)/configure.ac $(top_builddir)/config.log
+$(srcdir)/package.m4: $(top_srcdir)/configure.ac
:;{ \
echo '# Signature of the current package.' && \
echo 'm4_define([AT_PACKAGE_NAME],' && \
@@ -24,7 +21,6 @@ $(srcdir)/package.m4: $(top_srcdir)/configure.ac $(top_builddir)/config.log
echo ' [$(PACKAGE_BUGREPORT)])'; \
echo 'm4_define([AT_PACKAGE_URL],' && \
echo ' [$(PACKAGE_URL)])'; \
- $(ENABLE_NAT_TEST) \
} >'$(srcdir)/package.m4'
EXTRA_DIST = testsuite.at $(srcdir)/package.m4 $(TESTSUITE)