aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/libmsc/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2012-11-11 10:58:51 +0100
committerHarald Welte <laforge@gnumonks.org>2015-01-01 13:03:03 +0100
commitb4771a6871efb3cf12b371aedc575912984ca528 (patch)
treecfda932aa489b0ec304ceac51f2a6b123191714d /openbsc/src/libmsc/Makefile.am
parent7ff77ec713c6569715077344563ff9ab1719619c (diff)
Initial support for export + curses-visualization of measurements
This extends osmo_nitb to offer a UDP feed of real-time measurement reports, which can be used by (a variety of) external tools for visualization or other processing. We also add a small ncurses based tool (meas_vis) which shows a baragraph display of the last few mobile stations that were active, indicating their uplink/downlink receive level and quality. <WARNING> This sends non-portable structures like gsm_meas_rep over UDP and assumes the receiver has identical alignment and endianness! Before this feature is merged, it either needs to be converted to a unix domain socket (but they don't do multicast, which would be nice) or the wire format needs to change into something portable with defined alignment and encoding </WARNING>
Diffstat (limited to 'openbsc/src/libmsc/Makefile.am')
-rw-r--r--openbsc/src/libmsc/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/openbsc/src/libmsc/Makefile.am b/openbsc/src/libmsc/Makefile.am
index 24db2c2db..aa7d8ae99 100644
--- a/openbsc/src/libmsc/Makefile.am
+++ b/openbsc/src/libmsc/Makefile.am
@@ -2,6 +2,8 @@ AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)
AM_CFLAGS=-Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOVTY_CFLAGS) \
$(LIBOSMOABIS_CFLAGS) $(COVERAGE_CFLAGS)
+noinst_HEADERS = meas_feed.h
+
noinst_LIBRARIES = libmsc.a
libmsc_a_SOURCES = auth.c \
@@ -17,9 +19,9 @@ libmsc_a_SOURCES = auth.c \
ussd.c \
vty_interface_layer3.c \
transaction.c \
- osmo_msc.c ctrl_commands.c
+ osmo_msc.c ctrl_commands.c meas_feed.c
if BUILD_SMPP
-noinst_HEADERS = smpp_smsc.h
+noinst_HEADERS += smpp_smsc.h
libmsc_a_SOURCES += smpp_smsc.c smpp_openbsc.c smpp_vty.c smpp_utils.c
endif