aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/libiu/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <nhofmeyr@sysmocom.de>2016-05-20 21:38:32 +0200
committerNeels Hofmeyr <nhofmeyr@sysmocom.de>2016-08-27 13:29:30 +0200
commitbfa8878a0799c2d6bf29740ee10e84a69a938749 (patch)
treec27ee6a293e33bda8023c02f24360f7c603bd7dd /openbsc/src/libiu/Makefile.am
parent4ac3aee711ae88280c35c996b75bfff1f2415e87 (diff)
add libiu
Co-Authored by dwillmann, laforge, nhofmeyr Change-Id: Iffc26f9c73cb15463948f7435b72ac1747aabdb3
Diffstat (limited to 'openbsc/src/libiu/Makefile.am')
-rw-r--r--openbsc/src/libiu/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/openbsc/src/libiu/Makefile.am b/openbsc/src/libiu/Makefile.am
new file mode 100644
index 000000000..7b1ba4d19
--- /dev/null
+++ b/openbsc/src/libiu/Makefile.am
@@ -0,0 +1,10 @@
+AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)
+AM_CFLAGS=-Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOVTY_CFLAGS) \
+ $(LIBOSMOGSM_CFLAGS) $(LIBOSMOABIS_CFLAGS) $(COVERAGE_CFLAGS) $(LIBCRYPTO_CFLAGS) \
+ $(LIBASN1C_CFLAGS) \
+ $(LIBOSMOSIGTRAN_CFLAGS) $(LIBOSMORANAP_CFLAGS)
+
+noinst_LIBRARIES = libiu.a
+
+libiu_a_SOURCES = iu.c
+