aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/libcommon/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <nhofmeyr@sysmocom.de>2015-10-12 11:57:33 +0200
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2015-11-02 12:56:40 +0100
commitd48f057328cfb82b192d935325eb5af1162c0ecc (patch)
treee8e91969b6b2c5186b77572973fc222e35275c54 /openbsc/src/libcommon/Makefile.am
parentfe60cfb1d63d1c3b61c12eee78308f7985c66c1d (diff)
libcommon: soak up three static functions.
Add new kitchen sink openbsc/utils.h and libcommon/utils.c to make three so far static functions public (so I can use them in the upcoming OAP code). A place to put them could have been the gprs_utils.h, but all general functions in there have a gprs_ prefix, and todo markings to move them away. All other libcommon headers are too specific, so I opened up this kitchen sink header. Replace the implementation of encode_big_endian() with a call to osmo_store64be_ext(). See comments. Apply the change in Makefiles and C files.
Diffstat (limited to 'openbsc/src/libcommon/Makefile.am')
-rw-r--r--openbsc/src/libcommon/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/openbsc/src/libcommon/Makefile.am b/openbsc/src/libcommon/Makefile.am
index 75f40eea7..84c754452 100644
--- a/openbsc/src/libcommon/Makefile.am
+++ b/openbsc/src/libcommon/Makefile.am
@@ -6,4 +6,4 @@ noinst_LIBRARIES = libcommon.a
libcommon_a_SOURCES = bsc_version.c common_vty.c debug.c gsm_data.c \
gsm_data_shared.c socket.c talloc_ctx.c \
- gsm_subscriber_base.c
+ gsm_subscriber_base.c utils.c