aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2010-02-09 17:35:09 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-02-09 17:35:09 +0100
commit061947807313551d3255de4604c731cb757bb2a8 (patch)
treee042f2bacfb52b770541d0724b8b42735c0c54a5 /openbsc/src/Makefile.am
parentf8f184edab18b033eb8a63282477d737e41c145d (diff)
[nat] Intercept the PAGING message and then forward it to the BSCs with that LAC
* Provide access to the GSM0808 TLV attributes so we can use it in the nat code. * Read the PAGING message, if it is paged by LAC we go through each LAC and then attempt to find the proper BSC connection and then send the message to that BSC.
Diffstat (limited to 'openbsc/src/Makefile.am')
-rw-r--r--openbsc/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/openbsc/src/Makefile.am b/openbsc/src/Makefile.am
index 0e411775e..615884a38 100644
--- a/openbsc/src/Makefile.am
+++ b/openbsc/src/Makefile.am
@@ -43,5 +43,5 @@ isdnsync_SOURCES = isdnsync.c
bsc_mgcp_SOURCES = bsc_mgcp.c msgb.c talloc.c debug.c select.c timer.c telnet_interface.c
bsc_mgcp_LDADD = libvty.a
-bsc_nat_SOURCES = nat/bsc_nat.c nat/bsc_filter.c nat/bsc_nat_vty.c bsc_msc.c
+bsc_nat_SOURCES = nat/bsc_nat.c nat/bsc_filter.c nat/bsc_nat_vty.c bsc_msc.c bssap.c
bsc_nat_LDADD = libvty.a libbsc.a libsccp.a