aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2010-03-24 10:28:43 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-03-24 10:28:43 +0100
commitb9c520f9b36fd97ae11c91f2bec394d684ac6749 (patch)
treee312d0d70579eafa9e1fdc9c9c3daaf5a21f03fe /openbsc/src/Makefile.am
parent8a7ca57d3eec7376169661ea3cfcca4c3c2f33cf (diff)
parentf99f0930fd02a5ef164c54fe8926a7e0b11acbdb (diff)
Merge remote branch 'origin/master' into on-waves/bsc-master
Keep a static version as the shell script is not dealing well with branch tags/names containing text. Resolve merge conflict in the Makefile.am by adding both sides to the list of sources for the libbsc.a Conflicts: openbsc/configure.in openbsc/src/Makefile.am
Diffstat (limited to 'openbsc/src/Makefile.am')
-rw-r--r--openbsc/src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/openbsc/src/Makefile.am b/openbsc/src/Makefile.am
index 2c695993d..b920d0b65 100644
--- a/openbsc/src/Makefile.am
+++ b/openbsc/src/Makefile.am
@@ -1,4 +1,4 @@
-INCLUDES = $(all_includes) -I$(top_srcdir)/include
+INCLUDES = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)
AM_CFLAGS=-Wall $(LIBOSMOCORE_CFLAGS)
AM_LDFLAGS = $(LIBOSMOCORE_LIBS)
@@ -18,7 +18,7 @@ libbsc_a_SOURCES = abis_rsl.c abis_nm.c gsm_data.c gsm_04_08_utils.c \
input/misdn.c input/ipaccess.c \
talloc_ctx.c system_information.c rest_octets.c \
rtp_proxy.c bts_siemens_bs11.c bts_ipaccess_nanobts.c \
- bts_unknown.c telnet_interface.c meas_rep.c
+ bts_unknown.c telnet_interface.c meas_rep.c bsc_version.c
libmsc_a_SOURCES = gsm_subscriber.c db.c \
mncc.c gsm_04_08.c gsm_04_11.c transaction.c \