aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2010-03-29 12:48:36 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-03-29 12:48:36 +0200
commit5f1b7c14f58c38533b14424009edb8c1711fd122 (patch)
treefd35f10fca741996b1ba84985bf6b0e3227e9a06 /openbsc/src/Makefile.am
parent5b3e9198f008fe77e3d748e8e5d00f5af2de1dd9 (diff)
nat: Move creation of the structs to a separate file
This way one can create the bsc_nat structure in unit tests..
Diffstat (limited to 'openbsc/src/Makefile.am')
-rw-r--r--openbsc/src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/openbsc/src/Makefile.am b/openbsc/src/Makefile.am
index 219e1bd67..615758bed 100644
--- a/openbsc/src/Makefile.am
+++ b/openbsc/src/Makefile.am
@@ -52,5 +52,6 @@ bsc_mgcp_LDADD = libvty.a
ipaccess_proxy_SOURCES = ipaccess/ipaccess-proxy.c debug.c
-bsc_nat_SOURCES = nat/bsc_nat.c nat/bsc_filter.c nat/bsc_sccp.c nat/bsc_nat_vty.c bsc_msc.c bssap.c
+bsc_nat_SOURCES = nat/bsc_nat.c nat/bsc_filter.c nat/bsc_sccp.c \
+ nat/bsc_nat_utils.c nat/bsc_nat_vty.c bsc_msc.c bssap.c
bsc_nat_LDADD = libvty.a libbsc.a libsccp.a