aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/configure.in
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2010-07-30 02:53:14 +0800
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-07-31 04:09:38 +0800
commit30e1ae923db16c480cf210a29c8befa57a69202b (patch)
treefc64d6d9e4b4b7e3bb5b5e798ed284a2206b821f /openbsc/configure.in
parentc44db4a5341c1c86de784bb74d4dbd2063a4c010 (diff)
sccp: Use the external libosmo-sccp as sccp implementation
Add --enable-nat and --enable-osmo-bsc to build applications requiring the Osmo SCCP library to be installed. We are not using autodiscover as this is out of fashion.
Diffstat (limited to 'openbsc/configure.in')
-rw-r--r--openbsc/configure.in24
1 files changed, 21 insertions, 3 deletions
diff --git a/openbsc/configure.in b/openbsc/configure.in
index 50189a4aa..b877e6b84 100644
--- a/openbsc/configure.in
+++ b/openbsc/configure.in
@@ -22,6 +22,27 @@ AC_SEARCH_LIBS(gtp_new, gtp,
AM_CONDITIONAL(HAVE_LIBGTP, test "x$GPRS_LIBGTP" != "x")
+
+AC_ARG_ENABLE([nat], [AS_HELP_STRING([--enable-nat], [Build the BSC NAT. Requires SCCP])],
+ [
+ PKG_CHECK_MODULES(LIBOSMOSCCP, libosmo-sccp)
+ osmo_ac_build_nat="yes"
+ ],
+ [
+ osmo_ac_build_nat="no"
+ ])
+AM_CONDITIONAL(BUILD_NAT, test "x$osmo_ac_build_nat" = "xyes")
+
+AC_ARG_ENABLE([osmo-bsc], [AS_HELP_STRING([--enable-bsc], [Build the Osmo BSC])],
+ [
+ PKG_CHECK_MODULES(LIBOSMOSCCP, libosmo-sccp)
+ osmo_ac_build_bsc="yes"
+ ],
+ [
+ osmo_ac_build_bsc="no"
+ ])
+AM_CONDITIONAL(BUILD_BSC, test "x$osmo_ac_build_bsc" = "xyes")
+
PKG_CHECK_MODULES(LIBOSMOCORE, libosmocore >= 0.1.15)
PKG_CHECK_MODULES(LIBOSMOVTY, libosmovty >= 0.1.9)
@@ -47,9 +68,7 @@ AM_CONFIG_HEADER(bscconfig.h)
AC_OUTPUT(
openbsc.pc
- libsccp.pc
include/openbsc/Makefile
- include/sccp/Makefile
include/Makefile
src/Makefile
src/ipaccess/Makefile
@@ -61,6 +80,5 @@ AC_OUTPUT(
tests/gsm0408/Makefile
tests/db/Makefile
tests/channel/Makefile
- tests/sccp/Makefile
tests/bsc-nat/Makefile
Makefile)