aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Wild <ewild@sysmocom.de>2019-07-19 00:49:11 +0200
committerlaforge <laforge@gnumonks.org>2019-07-22 19:56:56 +0000
commitfdda613af57d18b5b292b209d440492da4b4c877 (patch)
treeb9166d926807fd634c6cba4cd1a37ae5b07606fe /configure.ac
parentefa7b9713361e89f9e337f0571e788c611c9ed64 (diff)
turn -Werror=null-dereference into a warning
There is unfortunately no way to suppres this witha pragma, and gcc 9 uncovers quite a few new instaces with enabled LTO that can't/won't be fixed Related: OS#4123 Change-Id: I615bb5be3671022c6b821575a61f945b50e8f2a5
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a2dfa5be3..bb8fb39b2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -117,7 +117,7 @@ dnl Checks for typedefs, structures and compiler characteristics
AX_CHECK_COMPILE_FLAG([-Werror=implicit], [CFLAGS="$CFLAGS -Werror=implicit"])
AX_CHECK_COMPILE_FLAG([-Werror=maybe-uninitialized], [CFLAGS="$CFLAGS -Werror=maybe-uninitialized"])
AX_CHECK_COMPILE_FLAG([-Werror=memset-transposed-args], [CFLAGS="$CFLAGS -Werror=memset-transposed-args"])
-AX_CHECK_COMPILE_FLAG([-Werror=null-dereference], [CFLAGS="$CFLAGS -Werror=null-dereference"])
+AX_CHECK_COMPILE_FLAG([-Wnull-dereference], [CFLAGS="$CFLAGS -Wnull-dereference"])
AX_CHECK_COMPILE_FLAG([-Werror=sizeof-array-argument], [CFLAGS="$CFLAGS -Werror=sizeof-array-argument"])
AX_CHECK_COMPILE_FLAG([-Werror=sizeof-pointer-memaccess], [CFLAGS="$CFLAGS -Werror=sizeof-pointer-memaccess"])