aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNeels Hofmeyr <neels@hofmeyr.de>2017-09-04 01:03:58 +0200
committerNeels Hofmeyr <nhofmeyr@sysmocom.de>2017-09-08 23:47:37 +0000
commit6c8afe148b6e0ef8e4edd6ea4fbbdb3e6134f94b (patch)
tree24585f9c65522db4498c879c95f9031d9d26604f /configure.ac
parentfb11041da90a21dd9426d0c37188f85ebd575edf (diff)
use separated libosmo-mgcp-client, apply rename to mgcp_client_*
After osmo-mgw changes I8e0b2d2a399b77086a36606f5e427271c6242df1 and I99f7faab637cfcc22ece64a1dbcbe590f2042187, apply linking of new libosmo-mgcp-client and renames to drop the "gw" from mgcp_client_*. Also rename the gsm_network.mgcpgw to mgw, to indicate that the MGCP client is used to contact the MGW (Media Gateway). Depends: I8e0b2d2a399b77086a36606f5e427271c6242df1 (osmo-mgw) I99f7faab637cfcc22ece64a1dbcbe590f2042187 (osmo-mgw) Change-Id: I093ad02ca0e532f659447c785e09678b3e6f220d
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 1 insertions, 28 deletions
diff --git a/configure.ac b/configure.ac
index dd61e52da..8f8bdb9e1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -47,7 +47,7 @@ PKG_CHECK_MODULES(LIBOSMOABIS, libosmoabis >= 0.2.0)
PKG_CHECK_MODULES(LIBOSMONETIF, libosmo-netif >= 0.0.1)
PKG_CHECK_MODULES(LIBOSMOSIGTRAN, libosmo-sigtran) # TODO version?
PKG_CHECK_MODULES(LIBCRYPTO, libcrypto >= 0.9.5)
-PKG_CHECK_MODULES(LIBOSMOLEGACYMGCP, libosmo-legacy-mgcp >= 0.0.1)
+PKG_CHECK_MODULES(LIBOSMOMGCPCLIENT, libosmo-mgcp-client >= 1.0.0)
# Enable/disable smpp support in the msc?
AC_ARG_ENABLE([smpp], [AS_HELP_STRING([--enable-smpp], [Build the SMPP interface])],
@@ -127,33 +127,6 @@ if test "$enable_coverage" = "yes"; then
AC_SUBST([COVERAGE_LDFLAGS])
fi
-AC_DEFUN([CHECK_LIBOSMO_LEGACY_MGCP_NEEDS_LIBGSM], [
- AC_CACHE_CHECK(
- [whether libosmo-legacy-mgcp needs -lgsm],
- libosmo_cv_legacy_mgcp_needs_libgsm, [
- SAVE_LDFLAGS="${LDFLAGS}"
- LDFLAGS="${LIBOSMOLEGACYMGCP_LIBS} ${LIBOSMOVTY_LIBS}"
- AC_LINK_IFELSE(
- [AC_LANG_PROGRAM([
- #include <osmocom/legacy_mgcp/mgcpgw_client.h>
- ], [
- mgcpgw_client_init(0, 0);
- ])],
- [libosmo_cv_legacy_mgcp_needs_libgsm=no],
- [libosmo_cv_legacy_mgcp_needs_libgsm=yes])
- LDFLAGS="${SAVE_LDFLAGS}"
- ])
- ])
-CHECK_LIBOSMO_LEGACY_MGCP_NEEDS_LIBGSM
-if test "x$libosmo_cv_legacy_mgcp_needs_libgsm" = xyes; then
- AC_SEARCH_LIBS([gsm_create], [gsm], [LIBRARY_GSM="$LIBS";LIBS=""],
- [AC_MSG_ERROR([libosmo-legacy-mgcp is built with transcoding and needs -lgsm but cannot find usable libgsm])])
- AC_SUBST(LIBRARY_GSM)
- if test "$osmo_ac_with_g729" = "yes" ; then
- PKG_CHECK_MODULES(LIBBCG729, libbcg729 >= 0.1, [AC_DEFINE([HAVE_BCG729], [1], [Use bgc729 decoder/encoder])])
- fi
-fi
-
AC_DEFUN([CHECK_TM_INCLUDES_TM_GMTOFF], [
AC_CACHE_CHECK(
[whether struct tm has tm_gmtoff member],