aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <neels@hofmeyr.de>2017-09-03 23:52:51 +0200
committerNeels Hofmeyr <nhofmeyr@sysmocom.de>2017-09-05 20:56:27 +0000
commit97df691307e48c39170ac39b2394a7095d7f0ee5 (patch)
tree1689ddf9faec8d7320ed9b01adce8363780029ad /Makefile.am
parentd049a66b791a5b98d25a075224f81622669c1ce0 (diff)
separate libosmo-mgcp-client from mgcp server code
When osmo-mgw is built --with-mgcp-transcoding, linking the mgcp library also requires linking libgsm, even though e.g. osmo-msc never use it. Separate the MGCP client code from the MGCP server code to avoid this dep. The mgcp client code does use some definitions from mgcp.h and mgcp_common.c. For simplicity, link mgcp_common.c in both libosmo-legacy-mgcp as well as libosmo-mgcp-client. That means it is not possible to link both libosmo-legacy-mgcp and libosmo-mgcp-client in the same binary because of duplicate symbols, but currently that is sufficient. (An alternative would be code dup or yet another libosmo-mgcp-common library.) Add libosmo-mgcp-client to debian packaging. Related: OS#2488 Change-Id: I8e0b2d2a399b77086a36606f5e427271c6242df1
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c5c3137cd..8fb6e6cc9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,7 +17,10 @@ SUBDIRS = \
$(NULL)
pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = libosmo-legacy-mgcp.pc
+pkgconfig_DATA = \
+ libosmo-legacy-mgcp.pc \
+ libosmo-mgcp-client.pc \
+ $(NULL)
BUILT_SOURCES = $(top_srcdir)/.version
EXTRA_DIST = git-version-gen osmoappdesc.py .version