aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac50
1 files changed, 22 insertions, 28 deletions
diff --git a/configure.ac b/configure.ac
index 4293635..9d7b634 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11,7 +11,9 @@ AM_INIT_AUTOMAKE([foreign dist-bzip2 no-dist-gzip 1.9 tar-ustar])
dnl tar-ustar: some asn1 filenames surpass the 99 char limit of tar, so we need
dnl to make tar allow longer filenames.
-AC_CONFIG_TESTDIR(src/tests)
+AC_CONFIG_TESTDIR(tests)
+
+CFLAGS="$CFLAGS -std=gnu11"
dnl kernel style compile messages
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
@@ -26,6 +28,13 @@ AC_PROG_MKDIR_P
AC_PROG_CC
AC_PROG_INSTALL
+dnl patching ${archive_cmds} to affect generation of file "libtool" to fix linking with clang
+AS_CASE(["$LD"],[*clang*],
+ [AS_CASE(["${host_os}"],
+ [*linux*],[archive_cmds='$CC -shared $pic_flag $libobjs $deplibs $compiler_flags $wl-soname $wl$soname -o $lib'])])
+
+AC_CHECK_HEADERS(netinet/sctp.h,,AC_MSG_ERROR(netinet/sctp.h not found))
+
dnl check for pkg-config (explained in detail in libosmocore/configure.ac)
AC_PATH_PROG(PKG_CONFIG_INSTALLED, pkg-config, no)
if test "x$PKG_CONFIG_INSTALLED" = "xno"; then
@@ -33,12 +42,12 @@ if test "x$PKG_CONFIG_INSTALLED" = "xno"; then
fi
PKG_PROG_PKG_CONFIG([0.20])
-PKG_CHECK_MODULES(OSMOCORE, libosmocore >= 0.12.0)
-PKG_CHECK_MODULES(OSMOGSM, libosmogsm >= 0.12.0)
-PKG_CHECK_MODULES(OSMOVTY, libosmovty >= 0.12.0)
-PKG_CHECK_MODULES(OSMOCTRL, libosmoctrl >= 0.12.0)
-PKG_CHECK_MODULES(OSMONETIF, libosmo-netif >= 0.3.0)
-PKG_CHECK_MODULES(OSMOSIGTRAN, libosmo-sigtran >= 0.10.0)
+PKG_CHECK_MODULES(OSMOCORE, libosmocore >= 1.9.0)
+PKG_CHECK_MODULES(OSMOGSM, libosmogsm >= 1.9.0)
+PKG_CHECK_MODULES(OSMOVTY, libosmovty >= 1.9.0)
+PKG_CHECK_MODULES(OSMOCTRL, libosmoctrl >= 1.9.0)
+PKG_CHECK_MODULES(OSMONETIF, libosmo-netif >= 1.4.0)
+PKG_CHECK_MODULES(OSMOSIGTRAN, libosmo-sigtran >= 1.8.0)
PKG_CHECK_MODULES(ASN1C, libasn1c >= 0.9.30)
AC_CONFIG_MACRO_DIR([m4])
@@ -121,42 +130,27 @@ then
AC_SUBST([OSMO_GSM_MANUALS_DIR])
fi
-# https://www.freedesktop.org/software/systemd/man/daemon.html
-AC_ARG_WITH([systemdsystemunitdir],
- [AS_HELP_STRING([--with-systemdsystemunitdir=DIR], [Directory for systemd service files])],,
- [with_systemdsystemunitdir=auto])
-AS_IF([test "x$with_systemdsystemunitdir" = "xyes" -o "x$with_systemdsystemunitdir" = "xauto"], [
- def_systemdsystemunitdir=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)
-
- AS_IF([test "x$def_systemdsystemunitdir" = "x"],
- [AS_IF([test "x$with_systemdsystemunitdir" = "xyes"],
- [AC_MSG_ERROR([systemd support requested but pkg-config unable to query systemd package])])
- with_systemdsystemunitdir=no],
- [with_systemdsystemunitdir="$def_systemdsystemunitdir"])])
-AS_IF([test "x$with_systemdsystemunitdir" != "xno"],
- [AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])])
-AM_CONDITIONAL([HAVE_SYSTEMD], [test "x$with_systemdsystemunitdir" != "xno"])
-
AC_MSG_RESULT([CFLAGS="$CFLAGS"])
AC_MSG_RESULT([CPPFLAGS="$CPPFLAGS"])
AC_OUTPUT(
+ libosmo-hnbap.pc
libosmo-ranap.pc
+ libosmo-rua.pc
+ libosmo-sabp.pc
src/Makefile
src/hnbap/Makefile
src/ranap/Makefile
src/rua/Makefile
- src/tests/Makefile
+ src/sabp/Makefile
+ tests/Makefile
Makefile
include/Makefile
include/osmocom/Makefile
include/osmocom/hnbap/Makefile
include/osmocom/ranap/Makefile
include/osmocom/rua/Makefile
+ include/osmocom/sabp/Makefile
include/osmocom/iuh/Makefile
doc/Makefile
- doc/examples/Makefile
- doc/manuals/Makefile
- contrib/Makefile
- contrib/systemd/Makefile
)