aboutsummaryrefslogtreecommitdiffstats
path: root/src/tests/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2016-01-03 16:31:31 +0100
committerHarald Welte <laforge@gnumonks.org>2016-01-03 16:31:31 +0100
commit056984fab1c1d6f80b5dc28f4c83eb80515d7c25 (patch)
tree464c52e786dddd420129f0f0a177b9e48e61f106 /src/tests/Makefile.am
parenta95d5a5f51d2dcc6b7bffdfe971148a6307e94d9 (diff)
merge (+rename) iu_helpers.c into libosmo-ranap
Diffstat (limited to 'src/tests/Makefile.am')
-rw-r--r--src/tests/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/tests/Makefile.am b/src/tests/Makefile.am
index 973cf3f..43b63cc 100644
--- a/src/tests/Makefile.am
+++ b/src/tests/Makefile.am
@@ -6,13 +6,13 @@ check_PROGRAMS = test-ranap test-helpers test-hnbap hnb-test dummy-cn
HNBAP_FILES = $(top_builddir)/src/hnbap_common.c $(top_builddir)/src/hnbap_decoder.c $(top_builddir)/src/hnbap_encoder.c
RUA_FILES = $(top_builddir)/src/rua_common.c $(top_builddir)/src/rua_decoder.c $(top_builddir)/src/rua_encoder.c
-HELPER_FILES = $(top_builddir)/src/iu_helpers.c $(top_builddir)/src/asn1helpers.c
+HELPER_FILES = $(top_builddir)/src/asn1helpers.c
test_helpers_SOURCES = $(HELPER_FILES) test-helpers.c
-test_helpers_LDADD = $(COMMON_LIBS)
+test_helpers_LDADD = $(COMMON_LIBS) $(top_builddir)/src/libosmo-ranap.la
test_hnbap_SOURCES = $(HELPER_FILES) $(top_builddir)/src/hnbap_common.c $(top_builddir)/src/hnbap_decoder.c test-hnbap.c test_common.c
-test_hnbap_LDADD = $(COMMON_LIBS) $(top_builddir)/src/hnbap/libosmo-asn1-hnbap.a
+test_hnbap_LDADD = $(COMMON_LIBS) $(top_builddir)/src/hnbap/libosmo-asn1-hnbap.a $(top_builddir)/src/libosmo-ranap.la
hnb_test_SOURCES = $(HELPER_FILES) $(HNBAP_FILES) $(RUA_FILES) hnb-test.c rua_helper.c test_common.c
hnb_test_LDADD = $(COMMON_LIBS) $(top_builddir)/src/hnbap/libosmo-asn1-hnbap.a $(top_builddir)/src/rua/libosmo-asn1-rua.a $(top_builddir)/src/libosmo-ranap.la