aboutsummaryrefslogtreecommitdiffstats
path: root/src/tests/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2015-12-25 15:34:22 +0100
committerHarald Welte <laforge@gnumonks.org>2015-12-25 15:34:22 +0100
commit87ffeb91dc52db2a9aac26b9cd851b3f8ffd0beb (patch)
tree558299b9f287a9fed3c0d0f05e530bb0c2c2c20f /src/tests/Makefile.am
parent3cfa450fdcc3cb9a47c05c3bc543cb493dd43b20 (diff)
factor out some common shared test init code
Diffstat (limited to 'src/tests/Makefile.am')
-rw-r--r--src/tests/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/tests/Makefile.am b/src/tests/Makefile.am
index 77b419a..3970f60 100644
--- a/src/tests/Makefile.am
+++ b/src/tests/Makefile.am
@@ -15,13 +15,13 @@ HELPER_FILES = $(top_builddir)/src/iu_helpers.c $(top_builddir)/src/asn1helpers.
test_helpers_SOURCES = $(HELPER_FILES) test-helpers.c
test_helpers_LDADD = $(COMMON_LIBS)
-test_hnbap_SOURCES = $(HELPER_FILES) $(top_builddir)/src/hnbap_common.c $(top_builddir)/src/hnbap_decoder.c test-hnbap.c
+test_hnbap_SOURCES = $(HELPER_FILES) $(top_builddir)/src/hnbap_common.c $(top_builddir)/src/hnbap_decoder.c test-hnbap.c test_common.c
test_hnbap_LDADD = $(COMMON_LIBS) $(top_builddir)/src/hnbap/libosmo-asn1-hnbap.a
-hnb_test_SOURCES = $(HELPER_FILES) $(HNBAP_FILES) $(RUA_FILES) $(RANAP_FILES) hnb-test.c rua_helper.c
+hnb_test_SOURCES = $(HELPER_FILES) $(HNBAP_FILES) $(RUA_FILES) $(RANAP_FILES) hnb-test.c rua_helper.c test_common.c
hnb_test_LDADD = $(COMMON_LIBS) $(top_builddir)/src/hnbap/libosmo-asn1-hnbap.a $(top_builddir)/src/rua/libosmo-asn1-rua.a $(top_builddir)/src/ranap/libosmo-asn1-ranap.a
-test_ranap_SOURCES = $(HELPER_FILES) $(RANAP_FILES) test-ranap.c
+test_ranap_SOURCES = $(HELPER_FILES) $(RANAP_FILES) test-ranap.c test_common.c
test_ranap_LDADD = $(COMMON_LIBS) $(top_builddir)/src/ranap/libosmo-asn1-ranap.a
# The `:;' works around a Bash 3.2 bug when the output is not writeable.